Bananian

Boot from Sata (UUID)

5 1762
Edited by Razzonkk at Dec 31, 2015 08:04

Hey,

I run the current Bananian on my Banana Pro and want to boot from a HDD.
At the moment I have changed the boot.cmd like this:
  1. root=/dev/mmcblk0p2 ---> root=/dev/sda1
Copy the Code


With this configuratuion it works, but I have read it's better to use the PARTUUID, so I tried this:
  1. root=/dev/mmcblk0p2 ---> root=UUID=61e4cffb-01
Copy the Code
Now the Banana Pro starts booting and the green LED flashs, but I can't connect via SSH and if I connect my monitor it stops after:
  1. Waiting for root device UUID=61e4cffb-01...
  2. [mmc-msg] sdc0 set ios: [...]
  3. mmc0: new high speed SDHC card at address 0007
  4. mmcblk0: mmc0:0007 SL16G 14.4GiB
  5. mmcblk0: p1 p2
Copy the Code

with blkid I got this:


and the boot-cmd looks like this:


What have I done wrong?
I hope you can help me

Razonkk

Unbenannt.PNG
Unbenannt2.PNG
Try using the filesystem UUID (the one starting with "307e...") and not the partition UUID

Thanks for your answer! But same problem as before.
Someone else any idea?

see if "root=PARTUUID=61e4cffb-01"  works....

No, the UUID= is the right one, but it is possible he needs an uinitrd ramdrive to resolve uuid or label statements, I posted instructions some time ago, you can find them here

keep in mind that the rest of your boot.cmd looks a lot diffrent to the one I'm using.

Thank you! Now it's working.
This is how I did it now:

  1. apt-get install u-boot-tools initramfs-tools fsprotect

  2. mount /dev/mmcblk0p1 /mnt

  3. mkinitramfs -o /mnt/initrd

  4. mkimage -A arm -T ramdisk -C none -n uInitrd -d /mnt/initrd /mnt/uInitrd

  5. #edit the boot.cmd

  6. mkimage -C none -A arm -T script -d /mnt/boot.cmd /mnt/boot.scr
Copy the Code

My boot.cmd is looking like this:
  1. setenv bootargs console=ttyS0,115200 console=tty0 console=tty1 sunxi_g2d_mem_reserve=0 sunxi_ve_mem_reserve=0 hdmi.audio=EDID:0 disp.screen0_output_mode=EDID:1680x1050p60 root=UUID=307e1531-ddaf-41c2-8f9c-cd0d57ba2269 rootfstype=ext4 elevator=deadline rootwait
  2. setenv bootm_boot_mode sec
  3. load mmc 0:1 0x43000000 script.bin
  4. load mmc 0:1 0x48000000 uImage
  5. load mmc 0:1 0x50000000 uInitrd
  6. bootm 0x48000000 0x50000000
Copy the Code
At the moment I don't want to use the newer kernel, so this should be ok?!

You have to log in before you can reply Login | Sign Up

Points Rules