Add-ons

Unable to Get Lemaker 5" Screen Working on Banana Pro with Lubuntu

6 1302
sibrod  
Hi,

I just received a Lemaker 5" screen and after following the instructions here http://forum.lemaker.org/forum.p ... 7190&extra=page%3D5, the Banana Pro would not boot; it just hung up with a steady green light.

I am using the Lubuntu image. I replaced script.bin with the one from git.hub and modified /etc/modules as directed. I have re-seated the screen cable several times. The Banana Pro booted fine with the LCD attached before I replaced the script.bin file (although with no image on the touchscreen), so I must assume that the problem is with the script.bin file I downloaded.

Has anyone got the Lemaker LCDs to work with the Lubuntu image? What am I doing wrong?

Thanks,
Rod
try reverting back to the original script.bin just to confirm it boots ok like before.

could also be a case of file-system corruption or sdcard not properly seated or sth.

if you have a uart cable you might connect and see where booting stalls.

sibrod  
I went back and tried the original script.bin and it booted O.K. I also restored my original image and went through the whole process again of replacing script.bin and the same thing happened. Unfortunately, I don't have a UART cable, but I guess I'd better get one.

I may also try Raspbian Wheezy and see if that makes a difference, although I'd really like this to work with Lubuntu.


I went back and tried the original script.bin and it booted O.K.

are you using ssh or do you have a hdmi monitor hooked in as well?

if you have a hdmi monitor connected,try removing it when using the lcd's script.bin

Is the Ribbon Cable properly seated and ribbon's blue tab facing Black locking piece on the white Connection?

I use a Banana Pro, Raspian Wheezy. I'm trying Armbian now,

Also, Check that you have a static address in /etc/network/interfaces for eth0. This way you can ssh log in, check dmesg, modprobe 5x_ts, and change script.bin.

sibrod  
Thanks very much for the suggestions, but unfortunately the screen still is not working.
I have tried the LCD with Raspbian with the same result that I had with Lubuntu: When I apply power, all I get are solid red and green LEDs and no activity.
I have tried this with both HDMI and the LCD Screen connected at the same time, and with only the screen connected, with both Raspbian and Lubuntu, with the same result--just solid red and green LEDs. I can't SSH into the Pi because it is pretty clear that the boot process never really gets going.

Each OS was on a different SD card.

I have seated and reseated the screen cable several times. The silver side of the cable is facing away from the Network Socket.

At what point in the boot process does script.bin come into play--at the very beginning? Does script bin require any special permissions, etc. Should I be copying script.bin as user root instead of bananapi?

Is there some way to independently test the screen to see if it is o.k.? When I use the old script.bin with the screen attached, there is no activity on the screen, but the system boots-I assume that is normal?


Thanks,
Rod

sibrod  
I have solved my problem!

Instead of trying to copy the new script.bin file using the banana pro itself, I instead copied the new script.bin file directly to my SD card on Windows. The screen now works perfectly.

Thanks all,
Rod

You have to log in before you can reply Login | Sign Up

Points Rules