Other OS

HiKey Kernel 4.4.0 with Ubuntu 15.10 - No Graphic

1 687
Hello everyone,
I just got hand on HiKey and so far I could done these few things to make some progress:
  • I could get the Kernel 4.4.0 aarch 64 compiled successfully and is working on HiKey.
  • I have managed to install a mini-rootfs as an another eMMC Grub option for managing the OS partition right inside the eMMC
  • My Ubuntu 15.10 OS just implemented in HiKey and I have reached the login prompt. So far these are working:
          - FrameBuffer is working fine with this kernel and I could get display on both Serial and TTY console. (Was not working on Kernel 4.1.x)
          - WiFi firmware and driver are all included in this kernel so I could get the WiFi working
          - Mali driver seams to work fine too. DMESG report it as loaded. I think is alright!

I tried to install a Desktop for my OS. However, the 'Lubuntu-Desktop' is not available for ARM64 architecture.
Therfore I tried to install 'Xubunu-Desktop'. Lightdm is not working as it crashes. Have no clue why?!
Any one can help please share!!!

Thanks,
S.GH
ELAR-Systems
http://www.elar-systems.com
  


mgfm99  
Using the snapshot image on 96boards, I could boot a 4.4.0 kernel but wasn't getting any screen output with the X server. I installed a copy of Arch linux and could get to the desktop using KDE and Gnome (3.18) - resource heavy but more useful with my touchscreen. The X server would fail, however, if I compiled the armsoc driver for Mali 450 that Linaro use (https://github.com/xin3liang/xf86-video-armsoc). Everything works with the fb driver but not the armsoc.
I'd also found earlier that upgrading to testing from Jessie would break the X server - the upgrade uninstalls xf86-video-armsoc since the newer X server interfaces directly with the kernel driver - this was on the 3.18 kernel.

You have to log in before you can reply Login | Sign Up

Points Rules