php fails because ld-lin} is not found

2 1776

I cannot run php e.g. to start owncloud or phabricator on my Banana Pi R1 running Bananian 15.08r1. I haven't used the machine for a while and updated today.

When I e.g. start php I get an error message:
  1. <div> php -v</div><div>PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/' - ld-lin} cannot open shared object file: No such file or directory in Unknown on line 0</div><div>PHP 5.6.17-0+deb8u1 (cli) (built: Jan 15 2016 17:58:43)</div><div>Copyright (c) 1997-2015 The PHP Group</div><div>Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies</div><div>    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies</div>
Copy the Code
It seems that somehow the json library is linked against a strange library with a broken name:
  1. <div>ldd /usr/lib/php5/20131226/                                                                                                 :(</div><div> => /lib/arm-linux-gnueabihf/ (0xb6fae000)</div><div> => /lib/arm-linux-gnueabihf/ (0xb6ebc000)</div><div>        /lib/ (0xb6fd7000)</div><div>        ld-lin} => not found</div><div>root@Ix /etc/apt # ls /lib/ld*</div><div>/lib/</div>
Copy the Code
Any ideas how to fix this other than compiling myself?

As a work-around I tried to create a symbolic link from / to /ld-lin{, but this only results in other errors:
php -v
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/' - /lib/arm-linux-gnueabihf/ undefined symbol: json_number_cxars in Unknown on line 0

did a little digging for you. is in this debian package.  I DL'd it from this page.  Saved it locally and
de-arced without installing with:

$> cd /tmp
$> dpkg -x php5-json_1.3.6-1_armhf.deb ./
$> cd /tmp/usr/lib/php5/20131226/
$> ls -tla ./
-rw-r--r-- 1 root root 26340 Aug  1  2014
$> ldd ./ => /lib/arm-linux-gnueabihf/ (0xb6f70000) => /lib/arm-linux-gnueabihf/ (0xb6e82000)
  /lib/ (0xb6f9c000)
$> ls -tla /lib/
lrwxrwxrwx 1 root root 30 Apr 14  2015 /lib/ -> arm-linux-gnueabihf/
$> ls -tla /lib/arm-linux-gnueabihf/
-rwxr-xr-x 1 root root 101684 Apr 14  2015 /lib/arm-linux-gnueabihf/ is in libc_2.19-18+deb8u3_armhf.deb downloadable from this page which you can unpack
without installing same as above and explore/compare contents with your installed version. I haven't
dug any deeper into this.  Hope that's some help though.

I fixed it by purging and re-installing the json_c library. I have no clue what has caused this.

You have to log in before you can reply Login | Sign Up

Points Rules