Trouble

SATA - Network Issue

4 636
Dear Bananians

I have a banana pi running open media vault. There is a 2.5 sata hdd attached. Everything worked fine for a while, but suddenly the blue led did not light up anymore after boot and no network access was possible.
When I boot with the sata cable unplugged it works fine (even though I leave the hdd power plugged in, it is supplied via the pi). I can even hotplug the sata cable and everything will work.

Does anyone have an idea what is the issue?

Thank you so much

Sunkissed
I just found out that it also works when I disconnect the hdd power and leave the sata plugged in. Maybe it is a power issue, but why did it work for two months?
I have a 2A power supply. And the hdd is a 1tb hitachi hgst with 5400rpm.

Perhaps your power supply is simply dying.

I would try with another PSU

Thanks. I tried with another 2A psu but unfortunately it didn't work. I do not have a stronger psu here but will try to get one and see if that helps.

I found the issue. The hdd file system was corrupted. I fixed it with fsck \dev\sda1
The problem was that boot halted when hdd mount was attempted.

You have to log in before you can reply Login | Sign Up

Points Rules