Discussion

Device not booting after emmc flash.

2 858
Lincoln  
I've followed the instructions on http://wiki.lemaker.org/HiKey%28LeMaker_version%29\"\"uick_Start and also those on https://github.com/96boards/docu ... iKeyGettingStarted.

The flash process runs as follows and completes without reporting errors. (I put the steps in a script names flashemmc, which is executed here with the -x option to echo the commands to screen.) ...

  1. $ sudo bash -x ./flashemmc
  2. <b>+ alias python=python2.7
  3. + ls /dev/ttyUSB0</b>
  4. /dev/ttyUSB0
  5. + read -p '*** Close Jumper 1 and Jumper 2, power up. Then press a key...' -n1 -s
  6. *** Close Jumper 1 and Jumper 2, power up. Then press a key...
  7. + echo ''

  8. <b>+ fastboot devices
  9. + python binaries/15.11/hisi-idt.py -d /dev/ttyUSB0 --img1=binaries/15.11/l-loader.bin</b>
  10. +----------------------+
  11. Serial:  /dev/ttyUSB0
  12. Image1:  binaries/15.11/l-loader.bin
  13. Image2:  
  14. +----------------------+

  15. Sending binaries/15.11/l-loader.bin ...
  16. Done

  17. + sleep 1
  18. <b>+ fastboot flash ptable binaries/15.11/ptable-linux-8g.img</b>
  19. < waiting for device >
  20. target reported max download size of 268435456 bytes
  21. sending 'ptable' (17 KB)...
  22. OKAY [  0.001s]
  23. writing 'ptable'...
  24. OKAY [  0.002s]
  25. finished. total time: 0.003s

  26. + sleep 1
  27. <b>+ fastboot flash fastboot binaries/15.11/fip.bin</b>
  28. target reported max download size of 268435456 bytes
  29. sending 'fastboot' (1389 KB)...
  30. OKAY [  0.041s]
  31. writing 'fastboot'...
  32. OKAY [  0.061s]
  33. finished. total time: 0.102s

  34. + sleep 1
  35. <b>+ fastboot flash nvme binaries/15.11/nvme.img</b>
  36. target reported max download size of 268435456 bytes
  37. sending 'nvme' (128 KB)...
  38. OKAY [  0.004s]
  39. writing 'nvme'...  
  40. OKAY [  0.005s]
  41. finished. total time: 0.009s   

  42. + sleep 1
  43. <b>+ fastboot flash boot binaries/15.11/boot-fat.uefi.img </b>
  44. target reported max download size of 268435456 bytes   
  45. sending 'boot' (65536 KB)...   
  46. OKAY [  1.771s]
  47. writing 'boot'...  
  48. OKAY [  2.834s]
  49. finished. total time: 4.605s   

  50. + sleep 10   
  51. <b>+ fastboot devices </b>
  52. 0123456789ABCDEF  fastboot  

  53. <b>+ fastboot flash system debian/15.11/hikey-jessie_alip_20151130-387-8g.emmc.img   </b>
  54. target reported max download size of 268435456 bytes   
  55. sending sparse 'system' (260454 KB)...  
  56. OKAY [  7.407s]
  57. writing 'system'...   
  58. OKAY [ 14.188s]
  59. sending sparse 'system' (260459 KB)...  
  60. OKAY [  7.534s]
  61. writing 'system'...   
  62. OKAY [ 16.695s]
  63. sending sparse 'system' (260424 KB)...  
  64. OKAY [  7.371s]
  65. writing 'system'...   
  66. OKAY [ 12.683s]
  67. sending sparse 'system' (260492 KB)...  
  68. OKAY [  7.567s]
  69. writing 'system'...   
  70. OKAY [ 20.353s]
  71. sending sparse 'system' (258533 KB)...  
  72. OKAY [  7.735s]
  73. writing 'system'...   
  74. OKAY [ 28.854s]
  75. sending sparse 'system' (262083 KB)...
  76. OKAY [  7.774s]
  77. writing 'system'...
  78. OKAY [ 26.015s]
  79. sending sparse 'system' (200149 KB)...
  80. OKAY [  6.415s]
  81. writing 'system'...
  82. OKAY [ 33.539s]
  83. finished. total time: 204.129s
  84. + sleep 2

  85. <b>+ fastboot devices</b>
  86. 0123456789ABCDEF  fastboot
  87. $
Copy the Code
At the start of the process none of the LEDs is lit. At the end one is lit.

I repeated this process, with and without the sleep delays, and with various small variations. In all cases it appeared to complete sucessfully.

After each flash I then powered down the board, opened the second jumper, attached HDMI, USB keyboard and mouse and powered it back up. The board lights LED04 for about a second, then turns it off and lights LEDS 01 and 03 for about a second, then turns them off and lights LED04 again. This cycle repeats indefinitely. The board shows no other dign of life and the HDMI monitor reports no signal.

At this point I'm stumped and I'm wondering whether the unit is defective, because;
  • I've never yet seen a signal on the LCD monitor. (The monitor is a ViewSonic VA1931wa, which has worked fine with everything else that's been connected to it, including other ARM dev boards.)
  • The unit exhibited this behaviour out of the box - it's never booted anything or shown any sign of life beyond the flashing LEDs.

Anyone have any ideas?

Thanks,
Lincoln

(I'm using;
  1. $ uname -a
  2. Linux lrickwood-ws 4.2.0-35-generic #40-Ubuntu SMP Tue Mar 15 22:15:45 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Copy the Code
in case that matters.)
Lincoln  
Lemaker technical support got back to me within 24 hours. They said (my italics);

According to your description, I am sure that your HiKey borad have started the OS properly. What you should do are:
  • Make sure that you have plugged HDMI plug in HDMI interface;
  • Check the HDMI-to-VGA cable or the display, try to use other HDMI-to-VGA cables or displays.
  • HiKey's power source is 8V-18V@2A.

They were right - the board is OK but it's very particular about the monitors it will work with. I tried four different LCD monitors and two different cables until I eventually found a combination that was able to display the desktop.

For reference;
  • Samsung S24C450 - Worked using a HDMI to DVI-I converter cable.
  • Samsung SyncMaster 940r - Did not work and gave no indication at all that it was seeing any signal from the board. (HDMI to DVI-I cable.)
  • ViewSonic VA1931wa - Did not work and gave no indication at all that it was seeing any signal from the board. (HDMI to VGA cable.) When connected to this monitor the board refuses to boot at all.
  • LG Flatron E1910 - Did not work but at least reported an out-of-range signal. (HDMI to DVI-I cable.)

Basically, it looks like you need a reasonably high-end modern wide-screen format LCD monitor. The various  'left-over' monitors lying about in the lab probably won't work.

Lincoln  
There are a few caveats to the claim that the Samsung S24C450 works;
  • The display does not come back correctly after the power management has put it to sleep. (Turning off "Handle display power management" in the Xfce Power Manager seems to fix this.)
  • The screens native resolution is 1920x1200, which is also the maximum resolution for the board. However, at this resolution the display eventually corrupts. The only solution I've found so far is to boot without HDM attached and then connect it, forcing the GPU to a resolution of 1280x720 as per http://wiki.lemaker.org/HiKey%28LeMaker_version%29:HDMI. This has worked without problems so far.
  • Pressing the AltGr-PrtScr-g key sequence is supposed to cycle the GPU through it's avaliable resolutions as per http://wiki.lemaker.org/HiKey%28LeMaker_version%29:HDMI. In practice this causes the monitor to blank and not recover.

(This whole thread should be under the HiKey/LeMaker forum rather than here - it got created in the wrong place. Sorry.)

You have to log in before you can reply Login | Sign Up

Points Rules