Interfacing

Banana Pi + 2,5" hard drive, having issues

6 966
sh0x  
Edited by sh0x at Apr 23, 2016 14:48

Hopefully I'm allowed to ask here, I'm new in the Single board computer world. I bought a Banana Pi pro with the Banana Pi Sata cable, I got myself a 2,5" hard drive and a 12W/2,4 A power charger.

I've plugged everything in and my Pi is working just fine but the hard drive is not running at all, when I plug it in via USB it's not working either, it looks like a power problem but normally it should be enough shouldn't it ?

I appreciate every bit of advice because I would love to have the SATA connection, otherwise I would go and buy a HDD docking station and get the USB 3.0 connection..

EDIT: It's running via USB but not via the Banana Pi SATA Cable.

EDIT2: dmesg prints out that the SATA link is down, can anyone help ?
igorpec  
There were some problems with u-boot not powering sata not long ago ... Which is your uboot and kernel version?

sh0x  
igorpec replied at Apr 24, 2016 00:42
There were some problems with u-boot not powering sata not long ago ... Which is your uboot and kern ...

Unfortunately I don't know how to find out which U-Boot version I'm running on. I'm using the Raspbian Image and it's running on Kernal Version 3.4.103

igorpec  
3.4.103
That's very old kernel and u-boot is probably stock Allwinner - almost 2 years. No idea which bugs are present there or if manifest this way. First upgrade to some recent and double check power condition, change power cables, ...

Edited by masterheese at Apr 24, 2016 14:42

I´m having the same Issue as sh0x, i´m using the Lemaker Raspbian for BananaPro Image.
Now i tried several way´s to update the Kernel but it wouldn´t worked for me.
Uname still shows the old Kernel, got anyone an Idea how to update it without compiling one on my own.
I tried:
rpi-update
then Lemaker Update script
and BPI update script
If you need more Information just ask.
Every little hint to the solution is a step in the right direction.
I choosed this Image because, i had some Issues with Bananian, because bananian was unable to locate packages, maybe if we could find a solution in this direction it´s still a way to solve my Problem.

Mit freundlichen Grüßen/ Best Regards

Masterheese

sh0x  
I installed Bananian on my Banana Pi Pro with the newest stable image and the newest stable kernel of the 4.4 versions. It's still not detecting the hard drive attached via the SATA cable, I found a work around for the newest version that suggested updating the u-boot files.

Out of this post: http://forum.lemaker.org/forum.p ... &extra=page%3D1

After that my Bananian didn't even boot anymore.

I appreciate every bit of advice because I would love to have the SATA connection, otherwise I would go and buy a HDD docking station and get the USB 3.0 connection.. PCCSA exam dumps

You have to log in before you can reply Login | Sign Up

Points Rules