Android & UART

15 883
GRAVITY  
Anybody know ?

GRAVITY  
tony_zhang replied at Dec 09, 2016 06:56
http://wiki.lemaker.org/Use_Java_to_control_GPIO_on_Android#UART

Tony, hello.

1. Firstly, i follow that instruction by that link. But not result.
DEBUG rx\tx is working perfectly in receive and send, but RX\TX0 is not working on SEND bytes from GUITAR (receive bytes on GUITAR is working OK).
I try few ttl-dongles, i try arduino to receive data from guitar - but all attempts to retrieve data (send via TX0) from the guitar were unsuccessful.

2. How can i use another pins to use UART ?

GRAVITY  
Hi. I solved the problem.

GRAVITY replied at Jan 12, 2017 15:51
Hi. I solved the problem.

How do you resolve it?

GRAVITY  
Edited by GRAVITY at Jan 13, 2017 04:20

Problem in denied permissions on /dev/ttyS0.
1. if i write chmod 0777 /dev/tty* from my android application - i can read bytes, but no send.
2. if i write only chmod 777 /deb/ttyS0 from ADB-utility - i can and read and write.
3. i got working sample if i write chmod 777 /dev/ttyS0 only from my android application - all pretty good work.

it is my mistake.

You have to log in before you can reply Login | Sign Up

Points Rules