Bananian

GPIOs w latest Bananian?

3 804
Ernesto  
Hi,

I am trying to find out how to activate the GPIOs in order to connect a
Onewire temperature sensor.
All documentation I can find uses

bin2fex and script.bin

but that seems to have gone away?

Whats the suggested way now with Debian 8?

Thank you!



  1. root@hotbananapi ~ # cat /etc/issue              
  2. Debian GNU/Linux 8 \n \l

  3. root@hotbananapi ~ # uname -a      
  4. Linux hotbananapi 3.4.111-bananian #5 SMP PREEMPT Fri Mar 25 17:24:42 UTC 2016 armv7l
  5. GNU/Linux
Copy the Code
Ernesto  
Can't believe no one is having that issue. Or maybe i am doing something fundamental wrong.

I tried the sunxi tools, both from the debian repo and from github.
When I trie to bin2fex the bin file (which seems now to be under (/usr/lib/u-boot rather then /boot) I get

Malformed format error.

Any suggestions?

Ernesto  
Ok, I can't believe it, but it was my own stupidity. I was looking on a running system in /boot for the script.bin whereas actually it's on the second partition /dev/mmblck0p2. This is also what the documentation states, but I overread it

Dear Ernesto,

I am also thinking to be able to use GPIOs on my BPi-R1 but I don not know what must I do/use.

Did you tried or think using wiringPi ?

You have to log in before you can reply Login | Sign Up

Points Rules