How to enter the u-boot "shell"

7 3365

Can somebody tell me, how to enter the u-boot shell when the Guitar starts?
I'd like to see the u-boot output (and not the LeMaker Logo), to stop the boot process by pressing any key and to enter the u-boot shell.

I am not sure I understand you but, have looked at this: http://wiki.lemaker.org/LeMaker_Guitar\"\"ebug_COM   
Did you hit Esc-button on the keyboard to get rid of the Logo.
Beside there are also the log files in /var/log/

Edited by mickpf at Aug 02, 2016 12:05


For some reasons (to change the u-boot env, to change the boot procedure, the boot order a.s.o.) I'd like to stop the boot process by pressing a key on the console (USB keyboard as input and HDMI as output) and to enter the u-boot shell. Nothing else...

Kind Regards

It normally should allow you to escape to u-boot prompt if the item allowed in u-boot.
I am pretty sure the option has been enabled in stock u-boot loaded into Guitar.
If not, compile the u-boot yourself and enable this option in u-boot settings (Similar to Kernel settings).
Set it for some time like 3 to 5 seconds to be able to escape to shell.

Not sure if I remember correctly, and if it was for Guitar or any other board I am working with, but
I do remember that you have to type something else and not just escape to get into shell.
You can have a look at u-boot source in GIT and see what has been set by default.

But I think it was "s500".

Edited by sghazagh at Aug 02, 2016 15:55

You made me curious to remember and find were was the setting!!!

Ok, the relevant setting for u-boot entry for Guitar has been set in :
<u-boot source>/include/configs/s500.h

If you have a look inside the file, there is a line:
  1. #define CONFIG_AUTOBOOT_DELAY_STR    "s500"
Copy the Code

You can have a look at the file here : https://github.com/LeMaker/u-boot-actions/blob/s500-master/include/configs/s500.h in line number 113.

Here is the string needs to be enter after pressing enter to allow you to get in to the uboot shell.
Actually the prompt also has mentioned that... It's right after the above config setting in line 114:

  1. #define CONFIG_AUTOBOOT_PROMPT                \
  2. "Enter %s to abort autoboot in %d seconds\n", CONFIG_AUTOBOOT_DELAY_STR, bootdelay
Copy the Code

And as you can see, it is set to "s500" and the prompt says:
  1. Enter s500 to abort autoboot in 2 seconds
Copy the Code

Delay time has been set on line 110:
  1. #define CONFIG_BOOTDELAY 2     /* autoboot after 2 seconds */
Copy the Code

You can modify any of these and compile the u-boot again to suit your needs.
Hope it helps

Hello sghazagh,

It's exactly, what I was looking for!

Thanks a lot!

No problem,
Happy to see that it helped.

Hello sghazagh,

I've tried it, but without any success!
I'm not clear: should I press <ENTER>, "s500" and <ENTER> ?
On the CompuLabs Utilite pro I need to press any key to break the autoboot process and enter the u-boot shell.

You have to log in before you can reply Login | Sign Up

Points Rules