[SOLVED]Is FreeBSD supported on Banana Pro?

8 3067
Edited by sokotica at Oct 05, 2016 00:06


Doas anyone know if is it possible to run FreeBSD on BananaPro?

Thanks in advance for your anwers.

I have FreeBSD running on my BananaPro, I used FreeBSD-11.0-ALPHA6-arm-armv6-BANANAPI-20160701-r302303.img.xz to install but FreeBSD-11.0-RC3-arm-armv6-BANANAPI.img.xz should work also.

Everything seems to work apart from the Wireless NIC.

Here it says Banana Pi is supported, it should be also Banana Pro... ... 20_Supported_Boards

I was trying to get FreeBSD running on my (SinoVOIP) BPi (M1) a few months ago but there were various issues such as USB not working plus no audio or IR support. If you have a LeMaker BPi you may have more luck.

I'd be interested to hear from anyone who has tried it more recently how much success you had.

I have Lemaker's Banana Pro, I have failed to make FreeBSD 10.3 (stable) run on it. The latest snapshot ... v6/ISO-IMAGES/10.3/
dated 08/09/2016 doesn't produce anything, while the one dated 07/14/2016 blink for a brief moment on a screen (I guess that is U-boot), but hangs afterwards.

Although FreeBSD's wiki says Banana Pi is supported, I can't make it to run on Banana Pro, allegedly the same board.

I've just had a quick go of FreeBSD-11.0-RC1-arm-armv6-BANANAPI.img on my sinovoip BPi M1. USB seems to be working now but HDMI out isn't working for me.

Also, the IR receiver and SPI are unsupported under FreeBSD.

The FBSD Allwinner wiki makes no mention of the BPro unfortunately

BananaPro isn't supported on FreeBSD FreeBSD-11.0-RC2. I have tried FreeBSD-11.0-RC2-arm-armv6-BANANAPI.img on BananaPro, it completes U-boot, and hangs afterwards, unable to boot.

Shame, if I had known this, i would have purchased BananaPi instead of BananaPro.

rk18 replied at Sep 15, 2016 16:10
I have FreeBSD running on my BananaPro, I used FreeBSD-11.0-ALPHA6-arm-armv6-BANANAPI-20160701-r3023 ...

Thanks for your support, I have finally managed to login through ssh freebsd pass freebsd. FreeBSD11-RC3 works on BananaPro (apart from HDMI), and I have discovered that I have a faulty USB to RS232 cable, so ssh was the only possibility left.

BTW, the gren light isn't blinking, I suppose it is because wi-fi doesn't work on FreeBSD yet, but I'm fine with ethernet.

You have to log in before you can reply Login | Sign Up

Points Rules