Other OS

Installing HAP-NodeJS and other packages to make Apple Homekit server

2 1616
Hello guys,

I purchased a Banana Pi A20 board thinking to make a secondary NAS that runs transmission torrent downloader, I already have an 4Tb WD NAS, but want another one that I can play with on other projects also, and one that just made me testing the Banana Pi board (purchased now 2 months ago, but never used it) was the new Apple HOME app that came with iOS 10, didn't knew about HomeKit but now I want to put some ESP8266 boards around my house, the first one is for a 12meters led strip I have in my office, I want to be able to turn it off from my phone.

I first tried to install the Bananian OS, than followed a the tutorial at the this address to install the needed software but whille installing  npm install node-persist && npm install srp && npm install mdns --unsafe-perm I got some errors, than I was thinking to try a different OS, 2016-07-13-raspbian-jessie-bpi-m1-m1p-r1.img and tried again and I got some errors again, I think the same errors showed up as I seen

  1. node-pre-gyp ERR! Tried to download: https://rvagg-node.s3-us-west-2.amazonaws.com/bignum/v0.12.5/bignum-v0.12.5-node-v47-linux-arm.tar.gz
  2. node-pre-gyp ERR! Pre-built binaries not found for bignum@0.12.5 and node@5.2.0 (node-v47 ABI) (falling back to source compile with node-gyp)
Copy the Code
this also showed up when I tried to install one by one all the modules
  1. root@bpi-iot-ros-ai:/home/pi/HAP-NodeJS# npm install curve25519

  2. curve25519@1.0.0 install /home/pi/HAP-NodeJS/node_modules/curve25519
  3. node-gyp rebuild
  4. make: Entering directory '/home/pi/HAP-NodeJS/node_modules/curve25519/build'
  5. CXX(target) Release/obj.target/curve25519/curve25519.o
  6. ../curve25519.cc: In function ‘v8::Handle V8Exception(const char*)’:
  7. ../curve25519.cc:14:44: error: ‘New’ is not a member of ‘v8::String’
  8. return ThrowException(Exception::Error(String::New(msg)));
  9. ^
  10. ../curve25519.cc:14:61: error: ‘ThrowException’ was not declared in this scope
  11. return ThrowException(Exception::Error(String::New(msg)));
  12. ^
  13. ../curve25519.cc: At global scope:
  14. ../curve25519.cc:18:51: error: ‘Arguments’ does not name a type
  15. static Handle node_curve25519_donna (const Arguments& args) {
  16. ^
  17. In file included from /root/.node-gyp/5.2.0/include/node/node.h:42:0,
  18. from ../curve25519.cc:1:
  19. /root/.node-gyp/5.2.0/include/node/v8.h: In function ‘v8::Handle node_curve25519_donna(const int&)’:
  20. /root/.node-gyp/5.2.0/include/node/v8.h:889:13: error: ‘v8::HandleScope::HandleScope()’ is protected
  21. V8_INLINE HandleScope() {}
  22. ^
  23. ../curve25519.cc:19:15: error: within this context
  24. HandleScope scope;
  25. ^
  26. ../curve25519.cc:23:12: error: request for member ‘Length’ in ‘args’, which is of non-class type ‘const int’
  27. if (args.Length() < 2) {
  28. ^
  29. ../curve25519.cc:29:29: error: invalid types ‘const int[int]’ for array subscript
  30. if( (Buffer::Length(args[0]->ToObject()) != 32) ||
  31. ^
  32. ../curve25519.cc:30:29: error: invalid types ‘const int[int]’ for array subscript
  33. (Buffer::Length(args[1]->ToObject()) != 32) ) {
  34. ^
  35. ../curve25519.cc:35:9: error: expected primary-expression before ‘*’ token
  36. Buffer* publicKey = Buffer::New(32);
  37. ^
  38. ../curve25519.cc:35:11: error: ‘publicKey’ was not declared in this scope
  39. Buffer* publicKey = Buffer::New(32);
  40. ^
  41. ../curve25519.cc:35:37: error: no matching function for call to ‘New(int)’
  42. Buffer* publicKey = Buffer::New(32);
  43. ^
  44. ../curve25519.cc:35:37: note: candidates are:
  45. In file included from ../curve25519.cc:2:0:
  46. /root/.node-gyp/5.2.0/include/node/node_buffer.h:28:40: note: v8::MaybeLocal node::Buffer::New(v8::Isolate*, size_t)
  47. NODE_EXTERN v8::MaybeLocal New(v8::Isolate* isolate, size_t length);
  48. ^
  49. /root/.node-gyp/5.2.0/include/node/node_buffer.h:28:40: note: candidate expects 2 arguments, 1 provided
  50. /root/.node-gyp/5.2.0/include/node/node_buffer.h:31:40: note: v8::MaybeLocal node::Buffer::New(v8::Isolate*, v8::Local, node::encoding)
  51. NODE_EXTERN v8::MaybeLocal New(v8::Isolate* isolate,
  52. ^
  53. /root/.node-gyp/5.2.0/include/node/node_buffer.h:31:40: note: candidate expects 3 arguments, 1 provided
  54. /root/.node-gyp/5.2.0/include/node/node_buffer.h:36:40: note: v8::MaybeLocal node::Buffer::New(v8::Isolate*, char*, size_t, node::Buffer::FreeCallback, void*)
  55. NODE_EXTERN v8::MaybeLocal New(v8::Isolate* isolate,
  56. ^
  57. /root/.node-gyp/5.2.0/include/node/node_buffer.h:36:40: note: candidate expects 5 arguments, 1 provided
  58. /root/.node-gyp/5.2.0/include/node/node_buffer.h:43:40: note: v8::MaybeLocal node::Buffer::New(v8::Isolate*, char*, size_t)
  59. NODE_EXTERN v8::MaybeLocal New(v8::Isolate* isolate,
  60. ^
  61. /root/.node-gyp/5.2.0/include/node/node_buffer.h:43:40: note: candidate expects 3 arguments, 1 provided
  62. ../curve25519.cc:37:46: error: invalid types ‘const int[int]’ for array subscript
  63. u8* privateKey = (u8*) Buffer::Data(args[0]->ToObject());
  64. ^
  65. ../curve25519.cc:38:45: error: invalid types ‘const int[int]’ for array subscript
  66. u8* basePoint = (u8*) Buffer::Data(args[1]->ToObject());
  67. ^
  68. ../curve25519.cc:42:18: error: ‘class v8::HandleScope’ has no member named ‘Close’
  69. return scope.Close(Localprocess.js:201:12)
  70. gyp ERR! System Linux 3.4.112-sun7i
  71. gyp ERR! command "/usr/local/bin/node" "/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
  72. gyp ERR! cwd /home/pi/HAP-NodeJS/node_modules/curve25519
  73. gyp ERR! node -v v5.2.0
  74. gyp ERR! node-gyp -v v3.0.3
  75. gyp ERR! not ok
  76. npm ERR! Linux 3.4.112-sun7i
  77. npm ERR! argv "/usr/local/bin/node" "/usr/local/bin/npm" "install" "curve25519"
  78. npm ERR! node v5.2.0
  79. npm ERR! npm v3.3.12
  80. npm ERR! code ELIFECYCLE

  81. npm ERR! curve25519@1.0.0 install: node-gyp rebuild
  82. npm ERR! Exit status 1
  83. npm ERR!
  84. npm ERR! Failed at the curve25519@1.0.0 install script 'node-gyp rebuild'.
  85. npm ERR! Make sure you have the latest version of node.js and npm installed.
  86. npm ERR! If you do, this is most likely a problem with the curve25519 package,
  87. npm ERR! not with npm itself.
  88. npm ERR! Tell the author that this fails on your system:
  89. npm ERR! node-gyp rebuild
  90. npm ERR! You can get their info via:
  91. npm ERR! npm owner ls curve25519
  92. npm ERR! There is likely additional logging output above.

  93. npm ERR! Please include the following file with any support request:
  94. npm ERR! /home/pi/HAP-NodeJS/npm-debug.log
Copy the Code

Anyone around to help me install the software I need on this banana Pi ?

Thank you.
Maybe with this image:

I'm downloading now jessie server, do I have more chances with the desktop version ?

You have to log in before you can reply Login | Sign Up

Points Rules