Bananian

GPIO, 1-wire, Bananian on BPi M1+. i can see only 1w master

3 1416
user3  
Hello, everyone!

I have BPi m1+, and i installed Bananian on this board.
Now i trying to setting GPIO. My steps after update:

#apt-get install build-essential
#apt-get install git
#git clone https://github.com/BPI-SINOVOIP/BPI-WiringPi.git -b BPI_M1_M1Plus
#cd BPI-WiringPi && chmod +x ./build && ./build
#gpio -v
gpio version: 2.26
Copyright (c) 2012-2015 Gordon Henderson

All ok, continue:
kernel:

#mount /dev/mmcblk0p1 /boot
#cd /boot
#bin2fex script.bin bananapi.fex
#nano bananapi.fex

[gpio_para]
gpio_used = 1
gpio_num = 40
gpio_pin_1 = portI00<1><default><default><default>
gpio_pin_2 = portB21<1><default><default><default>
gpio_pin_3 = portB20<1><default><default><default>
gpio_pin_4 = portH02<1><default><default><default>
gpio_pin_5 = portB03<1><default><default><default>
gpio_pin_6 = portI21<1><default><default><default>
gpio_pin_7 = portI14<1><default><default><default>
gpio_pin_8 = portI10<1><default><default><default>
gpio_pin_9 = portI13<1><default><default><default>
...
...
gpio_pin_40 = portH11<1><default><default><default>


#fex2bin bananapi.fex script.bin
#reboot

# modprobe gpio-sunxi
# lsmod
Module                  Size  Used by
cpufreq_powersave       1242  0
cpufreq_userspace       3540  0
cpufreq_stats           5892  0
cpufreq_conservative     5779  0
8021q                  18870  0
garp                    6092  1 8021q
stp                     2028  1 garp
llc                     5389  2 stp,garp

Module don't load.
but:
# ll /sys/bus/w1/devices
total 0
lrwxrwxrwx 1 root root 0 Nov 21 18:43 w1_bus_master1 -> ../../../devices/w1_bus_master1

i see only master. But connected 18b20 sensor.
what the reason? Where my mistake?

thanks for answers!







user3  
Edited by user3 at Nov 22, 2016 00:50

i forgotten, in bananapi.fex i added:

[w1_para]
gpio = 4

user3  
i think problem is in absence module.
I cant find him in bananian.
And module from rasbian don't work in bananian

user3  
i installed armbian.
All fine.

You have to log in before you can reply Login | Sign Up

Points Rules