Banana pi + Android + XMC + HDMI CEC

32 21725
Cyril  
Reply 10# ffwagner

Actually, I have no clues to investigate deeper.
I found http://linux-sunxi.org/A20 where we can see that the SoC A20 is compliant with CEC.

An other thing I have noticed: When the bPI is powered off, it scramble the CEC signals as all my devices connected to my TV set are no more recognised as CEC devices.

Post Last Edited by sashijoseph at 2014-8-21 00:42
I tried with the LUBUNTU rom and installed the libcec, but when I run the cec-client, there is no adapter found.
Cyril Posted at 2014-8-13 15:59


Which libcec are you using?
Have you compiled it yourself for the BPi?

Cyril  
Reply 12# sashijoseph


   No I don't, I installed it with apt-get.

kowal  
can you try install openelec or raspbmc? it has hdmi-cec support. i dont know what to buy raspberrypi or banana pi, but i need hdmi-cec support.

hdmi-cec hasn't been successfully tested on the BPi,not even on other Allwinner A20 devices.
The driver implementation is doubtful.

nerdros  
Reply 7# Cyril


   
I followed the instructions, and I added in the userdata folder the file playercorefactory.xml.
When I go to play a movie the following message appears: "External Player Active: Click OK when playback has ended".
I wonder if it is possible to use an external player with version xbmc present in the Mattrix's Android version.

Cyril  
Reply 16# nerdros

This happens when XBMC can not start the external player.please check:
- MX player is installed
- MX player codec is downloaded and installed
- MX player can read the movie file you are trying to watch through XBMC
- the playercorefactory.xml do not contain <filename>com.mxtech.videoplayer.pro</filename> to leunch the pro version, but
<filename>com.mxtech.videoplayer.ad</filename> to launch the free version

nerdros  
Reply 17# Cyril


Thanks Cyril. Everything you've listed I have already done.


In truth, the problem is due to the connection protocol that I use. I have movies on the NAS and connect my banana to nas using nfs. With nfs I get the error message, but if I connect the NAS using UPNP I have no error message but MXPlayer works.
Why nfs creates this problem?
Using UPNP does not work the scraper of the film. Why is that?
Thank you.

peterga  
Hi Cyril,

Did you find something new about the CEC within XBMC on banana pi?

Do you have any image that is already working with XBMC and CEC, I would also like to set up media center like bPI + XBMC + CEC.

Thanks

Hi everyone,

I am new to BananaPI and I am using Arch as Operating system on mine. That said the CEC kernel-module for the BananaPI does nothing, its just empty but it should initialise the hardware CEC port (as it does in/for the RasberryPI-Arch). Unfortualtely that is all I could find out so far and I have never tried to write a kernel-module. But I understand that xbmc and any other software cant work if the interface is never initialised.

Maybe this little piece of information helps, I would really appreciate any feedback and CEC on the BananaPI would be nice.

regards Trolerser

You have to log in before you can reply Login | Sign Up

Points Rules