Trouble

boot up going dead + what fixed it

9 3536
ged  
Yesterday I ran into a rather strange behaviour where my BananaPi would start up and boot for some amount of time and then randomly shutoff.
Sometimes this would happen when the boot messages were on the screen, sometimes when X was starting, sometimes just after X started.    Each time the machine would just go dead, the LEDs all went out.

I tried a whole number of things, including running with the SD Card I had been using with Raspbian stably for the previous 28 hrs.  It was a very frustrating problem, eventually after trying every combination of plugged/unplugged ports (no usbs, no hdmi, no network, different PS), I concluded that maybe the SD card had become corrupted some how.


The two things I tried together which seemed to work were:
1) Using SDFormatter Running a "Overwrite format" with the device compatibility alignment checkbox selected
2) Reducing my dd block size from 4M down to 1M


I'm not sure if it was either of these that caused the BPi to boot and run the image stably or if it was unplugging the BPi complete for 15 minutes while I ran those two commands...   Just thought I'd share in case anyone else hits this issue and is looking for something else to try.

Anyway there's some more experimenting I can do later, and I've order a CP2104 TTL to USB adapter to see if I can debug it more thoroughly should I see other boot problems in the future.
I have the same problem here. At first I burned Android 4.2 on my SD, seems good, booted normally, could check some settings in android (turned on ethernet) and then, zap-off. all lights turned off. Hit reset, booted for 2-3 times, it booted but in Android it sucked after a few min. and shut down. (At this point I added a heatshink to the CPU)
So I wanted to check if its the Android build and installed XBMC. Same here, sometimes it started normally, sometimes it took a few resets until running... I tried to play a 1080p movie but that was shitty... So lets try lubuntu. That one ran perfecly...but still bad video performance.
AND NOW: I tried all of them again to boot, but eryone fails. I get some text lines but the it shuts up. (all led off)
Tried SDFormatter in Override Mode... no change.
On Android I get the green Android screen, then nothing changes, when resetting it chrashes after ~4sec of green Android screen, after second reset ~2sec, after 3rd ~1sec... each time worse.
I have tried 4 different Cards (8,8,16,32 Gig, Classes 4,10,10,10, all class 10 write ~17MB/s)

Is there someone with same problems ? Or any suggestions ?

You could run a check on your power supply just to rule out an undervoltage/current being supplied.

Ok, you got it, thanks.
I was runnig it on a 4A rated USB Hub PSU, but it did not work. Now Im using a Laboratory PSU with a very short usb cable ( thes shitty things...) and the PSU tells me it draws 0,7A peak, 0,3A-0,5A in normal use. Now i got it running stable.
thanks

ged  
Looks like the solution was a temporary one...   made it to an uptime of 1 day, 18:18:28 before it powered off again.

It's crashing all the time now, I had a byobu session running with 2 panes with the following:
watch 'dmesg | tail -$((${LINES} - 5))'
multitail /var/log/{syslog,kern.log,auth.log,dpkg.log,Xorg.0.log}

Unfortunately, it didn't capture what is happening...    I can see the CPU is only at 29C, so it's not a heat issue, I switched from at 2.4A PSU to the iPad Mini PSU (2.1A)...   Maybe I can try a different USB cable, not sure why that would make a difference.

Until my TTL to USB arrives, I'm not sure how I can debug this.

ts101  
Same problem here! Banana Pi with latest Raspbian image from lemaker repository.

I can run the BPI for a few minutes until it shuts off either completely (no more LEDs and everything else dead) or with only the red LED turning off and no longer responding while still flashing the blue LED on network traffic.

I started out fine for about a day without any problems. After the first crash I could still recover system functionality by fsck'ing the SD card under my laptop's ubuntu. That does no longer work as now it shuts off during boot.
The serial console (on J11) outputs nothing special, just what you would see during a normal boot until it suddenly stops.
I tried switching from walwart to lab PSU but no change. I did notice, though, that right before powering off the Pi draws more than 1A for a few milliseconds while otherwise it runs on 300mA to 700mA.

Will try other OS on the SD card next and if unsuccessful new SD card next week. I'll keep you posted...

ts101  
Well, no luck with reformatting the SD card and using another OS...

Also, the time it takes for the BPI to shut off seems to get shorter. I wonder if it will start at all in a few hours... Could be some part deteriorating under power.

Will try further.

ts101  
Strange thing happening this morning. When I came back to work today and tried the new SD card I brought from home everything worked well. And here it comes: The other SD card (the one from last week) with the (then) non-working OS on it suddenly started working as well. Since then I ran some tests on it (giving the CPU something to work, benchmarking the SD card, etc.) but it's stable as of now.
Suddenly disappearing faults leave me a little unsettled, but that's how it is. Maybe it will come back. Will report if it does.

A zombie bananapi back from the dead...

I had a dead banana pi por and I run into this issue.
Made a clean sd card bananian 15.08 and booted it.
After that I booted my old SD card perfectly. This is and odd behaviour.

You have to log in before you can reply Login | Sign Up

Points Rules