Bananian

BananaPi - Can't upgrade from 15.04 r01 to 16.04

0 789
Hey,

Just decided to "clean dust" from my old BananaPi. I've done bananian-update and it bumped my version from 15.01 (if I remember correctly) to 15.04 r01. But on site I've seen, that it's a legacy version and right now newest is 16.04 - and, according to a description, I should be able to upgrade by using bananian-update. However, it's output looks like this:

root@BANAN:~# bananian-update
---------------------------------------------------------------------------------
Welcome to bananian-update!

This script upgrades your Bananian installation.

For news and updates check: http://www.bananian.org

Don't panic, you will be asked to confirm before applying any updates!

---------------------------------------------------------------------------------
receiving/updating public key...

gpg: failed to start the dirmngr '/usr/bin/dirmngr': No such file or directory
gpg: connecting dirmngr at '/root/.gnupg/S.dirmngr' failed: No such file or directory
gpg: keyserver receive failed: No dirmngr

---------------------------------------------------------------------------------
downloading latest upgrade from dl.bananian.org... (this might take a while)

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 14.4M  100 14.4M    0     0  4719k      0  0:00:03  0:00:03 --:--:-- 4722k
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   819  100   819    0     0   1508      0 --:--:-- --:--:-- --:--:--  1508

---------------------------------------------------------------------------------
verifying signature...

gpg: assuming signed data in '/tmp/tmp.wCZT6xhAr9/update.tar.gz'
gpg: Signature made nie, 16 sie 2015, 20:11:55 CEST
gpg:                using RSA key 1456A3B424BFF712
gpg: Good signature from "Nico Isenbeck (Bananian Linux) <download@bananian.org>" [ultimate]

signature okay.

---------------------------------------------------------------------------------
extracting upgrade...


---------------------------------------------------------------------------------
You are using Bananian 15.04 r01
---------------------------------------------------------------------------------

Your Debian version is unknown/not supported.
Please make sure /etc/debian_version contains the correct version number.



root@BANAN:~# cat /etc/debian_version
9.0



I'd be very grateful for any help/suggestions,
Greg

You have to log in before you can reply Login | Sign Up

Points Rules