Interfacing

USB wifi dongle coherent_pool issue

1 446
arronar  
Hello.

I have a banana Pi with Bananian OS. I plugged in a USB wifi dongle (TP-LINK) and I'm getting the following error at dmesg command.
[  292.756927] usb 1-1: new high-speed USB device number 2 using sw-ehci
[  292.918111] usb 1-1: New USB device found, idVendor=0bda, idProduct=8179
[  292.939548] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  292.950004] usb 1-1: Product: 802.11n NIC
[  292.957289] usb 1-1: Manufacturer: Realtek
[  292.964904] usb 1-1: SerialNumber: 00E04C0001
[  293.032415] sw_usb_enable_hcd: usbc_num = 2
[  293.187337] ERROR: 256 KiB atomic DMA coherent pool is too small!
[  293.187349] Please increase it with coherent_pool= kernel parameter!
[  293.206139] usbcore: registered new interface driver rtl8188eu

While searching on the internet I found that a possible solution could be to add the "coherent_pool=2M" at the uEnv.txt . The thing now is that I cannot find the location of that uEnv.txt . It is neither on /boot nor at the /dev/mmcblk0p1 when tried to mount it at /mnt.

In reality /boot directory has :
  1. config-3.4.111-bananian  config-3.4.113-bananian  System.map-3.4.111-bananian  System.map-3.4.113-bananian  vmlinuz-3.4.111-bananian  vmlinuz-3.4.113-bananian
Copy the Code
while the /dev/mmcblk0p1 has :
  1. boot.cmd  boot.scr  fex  script.bin  uImage
Copy the Code


There is nowhere the uEnv.txt.

I also tried to find it using

  1. <div>sudo find / -name uEnv.txt</div><div></div>
Copy the Code


Any idea or hint is welcome.
Hello,
   In my case I found a file called /boot/armbianEnv.txt. I edited the file and added "coherent_pool=2M".
try:
$ sudo updatedb
$ locate  Env.txt
I hope it helps.
Pedro

You have to log in before you can reply Login | Sign Up

Points Rules