Android 4.4 (Beta 1)

32 23097
dlanor  
So this Android 4.4 is no real improvement on the old image, with the main differencies being that they got rid of that silly Tdvlauncher (which mattrix already got rid of for his 4.2 image), but added total loss of functionality for the right mouse button. (just does the same as left button).

As I see it 'upgrading' to this version would be pointless, as what I have now with 4.2 works better. I did try it, but found it pointless to go on with mouse effectively reduced to a single button, instead of three. (In 4.2 the wheel button acts as Android 'Menu' button, but in 4.4 it's just another duplicate of the left button.)

If it was possible to fix that mouse mess-up I might reconsider, but the way 4.4 works now I see it as a 'dud' release.

Best regards: dlanor

ged  
I tried the image, but never got past a weird "purple" screen...  guess it's back to the other images.

I tried the image, but never got past a weird "purple" screen...  guess it's back to the other image ...
ged Posted at 2014-8-13 21:33


Purple screen?   There should be springing balls when booting.


Another news, an (official?) Banana pi channel uploaded a video demonstrating Android 4.4 Beta and its video playback capabilities...
https://www.youtube.com/watch?v=mssPk0hIcuU

ged  
Right before I get my purple screen I get a whole bunch of untracked pid exited messages in the TTL output

  1. [   16.226123] [sw_udc]: sw_udc_pullup, is_on = 1
  2. [   16.233826] WRN:L2771(drivers/usb/sun7i_usb/udc/sw_udc.c):ERR: usb device is not active
  3. [   16.250530] init: using deprecated syntax for specifying property 'sys.usb.config', use ${name} instead
  4. [   16.285496] getprop used greatest stack depth: 5328 bytes left
  5. shell@wing-k70:/ $ [   16.551437] ###########close all layers 0, hdl 103
  6. [   16.822607] ###########close all layers 0, hdl 103
  7. [   17.657181] init: untracked pid 1556 exited
  8. [   17.661949] init: untracked pid 1558 exited
  9. [   17.674425] init: untracked pid 1560 exited
  10. [   17.679218] init: untracked pid 1562 exited
Copy the Code

ged  
Post Last Edited by ged at 2014-8-14 23:58

I suspect the problem was that I was plugged into a monitor, not a TV...

I reformatted the SD card and tried with a TV and eventually got into 4.4.

Lots of ANRs, probably need a faster SD card.

Installed SPMC on it, seems to work okay, no audio however.
Also no overscan control, so top and bottom of screen don't fit on my 720p LG TV.

vmlite  
Here is a video with XBMC and YouTube playing videos very smoothly on Android 4.4:

According to the main author, the output resolution is fixed to 1024x600, so subHD. The video is 720p, so not there yet. The gpu should be able to decode 4K video, so quite the leap.

vmlite  
They are building 1920 * 1080 Android OS image, will release on http://www.bananapi.com, this is a screenshot from my early tests.

1920*1080 screenshot

1920*1080 screenshot

1cf2  
New 4.4 not support my TV,Samsung LA46A550 which 4.2 working with it without any problem.

past  
Is bluetooth supported in 4.4?

You have to log in before you can reply Login | Sign Up

Points Rules