Problems running Banana Pro

8 1073
Hi all !

I would like tro get some help as I bought a BananaPro and in no way I can make it go. I bought few different power supplyies, I tried 3-4 different SD cards
and lastly i tried with arduino to get anything from the UART debug header. And after all of that nothing.

I get the red led light up and no signal on hdmi or ttl dewbug header.

If I try another power supply, the last one i bought the red light starts flashing, i could not find anything about what this flashing means ?

But when experimenting with arduino and the serial console , i got the green, blue and red leds light up in few ocasions .

Once i noticed that if I take off the power supply the power led still lights up if the arduino and banana are connected with the ttl debug header.

The 3 leds light up when I load the simple program to arduino enabling the TX/RX pins 0 and 1 for enabling the seril console.

Unfortunately at no baud speed I can get anything from bananapro.

Is my banana pro broken or i do miss anything ?


Hi, nobody can suggest anything ?

how can i make sure the Bpi is not bricked ?

I am sad to see that there is no answers or suggestions on my issue.

By the way, why does the red led blink ? What would that mean ?

Is there some other way I could get some help with this ?

It seems that these forums are not very much used by community if there is an community.

this is really frustrating, sorry to see so low activity, except for spam.

Ok right now I just changed the USB cable and all started to work, huh. I could not immagine a cable could make a so big difference for this thing. Strangely Raspberry Pi works with the other cable without any troubles....

Ok, now its all ok, already have Arch Linux running.

You have to log in before you can reply Login | Sign Up

Points Rules