Force Screen Resolution

19 27504
Im trying to set a Resolution for my hdmi graphics Output. Im using the lubuntu image from this site.
Ive tried to configure it with xrandr by adding modes.
Nothing worked at all. The only existing output device is "default" and its Resolution is automaticly set to the device standard.
(tried different HDMI devices). I cant do any changes with the GUI because theres only the current auto-detected resolution in the list. I want that only one specific resolution (1024x600) is used for any device i plug in.

Any ideas?

kind regards
Try "fbset -xres 1024 -yres 600" in a terminal

Try "fbset -xres 1024 -yres 600" in a terminal
sashijoseph Posted at 2014-8-13 17:43

  Thank you, i tried it but it didnt work out.... screen turns off and on again, but resolution stays the same...I cant understand this, it sets itself to a resolution it detects (example: my hdmi desktop monitor 1920x1080, my lcd  screen 1200x800) but it doesnt accept resolutions i want...

really strange..

It chooses the resolution when its booting up, so shouldnt there be a config file where i can disable "auto" resolution?

any other advices?

thanks in advance

Try changing the uEnv.txt file in the boot sector. It always installs with 1280x720. Should work if you just want the one resolution. I used it to scoot the overscan in with 1360x768. Works like a charm.

Changing the uEnv.txt file didnt make any chances to me... Could you post the content of your uEnv file?

Make sure you disable EDID in the uEnv.txt...

The screen output-mode field should look sth like :

instead of

Use the desired resolution instead of 1280x720p above...

Already did that, but the resolution is always "1280x720" when i remove the EDID part, no matter whats plugged in... but it wont take the resolution ive written into the file...

Thats a really strange behaviour especially when it works for you....

Well then it looks like the display drivers won't take any arbitrary resolution thrown at it....
There are a set of standard resolutions and 1360x768 is one of them,probably that's why it worked for ryjyd.
The other ones seem to be 720p,1080p,1280x1024.
you could try one of these just to confirm if this indeed is the case...

I think sashi is on to something. Look in here: Menu item #18. I picked a common resolution by chance. That one is on the list. I don't see 1024x600. You might be able to get that out of an LCD, but probably not the HDMI. Obviously this is just for the fex file, but fex works in conjunction with the uEnv.txt file. Could be a core/driver thing, dunno. How things work is more my thing, not so much why things work.

Post Last Edited by mantisghost at 2014-8-26 01:54

I have similar problem. lubuntu seems to recognize native resolution of my screen but the desktop is bigger than my screen in other means taskbar is not visible folder icons are cut in half on the left side etc. I did try many ways to fix this still cant find solution. When i try to change with fbset my screen shows unsupported resolution message and thats all removing EDID in uENV.txt had no effect. I did try to use xrandr and that did not help either. I am aware that this may be because of the screen I use theere are almost no option to change video in it so i can do so only in the OS. Any suggestions?

You have to log in before you can reply Login | Sign Up

Points Rules