Lubuntu

Force Screen Resolution

19 24175
Fab  
After setting the bananpi I still was having problem. I fixed it changing some settings in the TV.
See:
http://forum.lemaker.org/1577-1- ... th_screen_size.html

Hope this helps

Reply 10# mantisghost

Hi mantisghost.
Sounds similar to my situation when I first booted. But it wasn't graphics resolution that was the issue for me. It was my Hitachi TV settings. I went into the picture menu and changed the zoom setting and the picture suddenly fitted.

Hope this helps. Good luck if not.

Here http://wiki.lemaker.org/FAQ Q16 has another solution

Sadly this not help I have almost no options when it comes to screen option menu. There is only contrast, brightness, color theme and switching from 16:9 to 4:3 thats all so I must do it somehow in linux

artur  
@Timo, did you found the solution?

I have the same problem..

Hi everyone,

I have the same problem. I bought a 7-inch touch display with 1024x600 resolution for the use with Raspberry and Banana Pi.

With Raspberry Pi the configuration was no problem as you can directly set all resolution parameters in the config.txt. Only with Banana Pi I did not get the special resolution working at first. After reading a lot of forum posts I finally tried the following:

- Open /etc/fb.modes
- Add these lines:
  1. mode "1024x600-76"
  2.     # D: 65.003 MHz, H: 48.365 kHz, V: 75.807 Hz
  3.     geometry 1024 600 1024 1200 32
  4.     timings 15384 160 24 29 3 136 6
  5.     rgba 8/16,8/8,8/0,8/24
  6. endmode
Copy the Code
(The timing values I found out by testing. Maybe they differ for your display.)

Then on a console then you just have to enter
  1. fbset 1024x600-76
Copy the Code
If the resolution is fine then you can add the fbset command to the /etc/rc.local file.
Hope that helps you. At least it is a work around... ;-)

Great job!

Litte addition:

I just checked the framebuffer settings in the Raspberry Pi environment using the modified config.txt values. With the same display the fbset command gives me here:
  1. mode "1024x600"
  2.     geometry 1024 600 1024 600 16
  3.     timings 0 0 0 0 0 0 0
  4.     rgba 5/11,6/5,5/0,0/16
  5. endmode
Copy the Code
So if the values above does not work for you these minimal values should do it as well...

And another person with a similar, but slightly different problem ...

I have no screen connected to the Banana Pi, because I want to operate it exclusively via x11vnc. So far, Ihave tried setting /boot/uEnv.txt and creating a xorg.cong, but - as you may guess - it always boots up in 1280x768. The desired resolution is 1360x768 or 1440x900, because that's the largest I can sho on the screen of my VNC client.

About the /boot/uEnv.txt ...
I'm not sure if I did it right. Originally, it was completely empty. I found some examples conteining bootargs=... but others only speak about the disp.screen0_output_mode. So, I used the file from the raspbian SD card that was in the package, and this is my current version:

  1. bootargs=console=ttyS0,115200 console=tty0 disp.screen0_output_mode=1360x768p50 hdmi.audio=EDID:0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
  2. aload_script=fatload mmc 0 0x43000000 bananapi/script.bin;
  3. aload_kernel=fatload mmc 0 0x48000000 bananapi/uImage; bootm 0x48000000;
  4. uenvcmd=run aload_script aload_kernel
Copy the Code
I also removed the hdmi.audio=EDID:0 part, but again ... no success.

There is another thing that confuses me. In the FAQ, they say you can query the available resolutions via
  1. cat /sys/class/graphics/fb0/modes
Copy the Code
but other than mentioned in the FAQ (12 results), I get only 1280x720 as result.

I have installed fbset. But whatever resolution I try, it says "unknown resolution".

I'm using the Arch Linux image from lemaker.

Guys, don't use /boot/uEnv.txt.. Instead try to make changes in uEnv.txt file at /dev/mmcblk0p1.

Try this:
sudo mount /dev/mmcblk0p1 /mnt
sudo nano /mnt/uEnv.txt

make the changes you want at parameter disp.screen0_output_mode. I didn't use EDID too...
save the file
reboot

I'm using Archlinux.

I Hope it helps

You have to log in before you can reply Login | Sign Up

Points Rules