Other Projects

Minecraft on BP (need help)

5 9743
I am a minecraft crazy fan. Since i know the the minecraft I Edition( for raspberry pi), i wanna try it on the BP, but meet some problems.
I log my process here, and i will still try to solve, i wanna be a miner!!

first click the LXTerminal icon to open a terminal window, and type this command:
  1. wget https://s3.amazonaws.com/assets.minecraft.net/pi/minecraft-pi-0.1.1.tar.gz
Copy the Code
after download the package, use the following  command to unzip the contents:
  1. tar -zxvf minecraft-pi-0.1.1.tar.gz
Copy the Code
then go in to the folder, and mine it:
  1. cd mcpi
  2. ./minecraft-pi
Copy the Code
if everything it's ok,  the minecraft window should open.

here is my problem, after ./minecraft-pi , it shows:
  * failed to open vchiq instance

seems vchiq is a driver in kernel, i am not sure.
so i google this problem, some guy say try this
sudo chmod 777 /dev/vchiq

but the /dev/vchiq is never exists, So this maybe the problem.

BTW, the vchiq is necessary for xmbc. I dont know whether some one successful run the XMBC on BP. If not ,maybe this problem we need to solve first.
There is no gpu support yet, whole raspian runs of the cpu. Minecraft uses gpu = no support for minecraft. Maybe you can do some coding in Minecraft so it runs of cpu. I believe they are developing gpu support but I'm not sure.

For me, Minecraft Lancher starts on Ubuntu 14.04.1 LTS..
Here's short how-to:
cd ~/Downloads/
mkdir minecraft
cd minecraft
wget https://s3.amazonaws.com/Minecra ... ncher/Minecraft.jar
sudo apt-get install openjdk-7-jre
export LD_LIBRARY_PATH="/usr/lib/jvm/java-7-openjdk-armhf/jre/lib/arm"

Then start with:
java -Xmx512M -Xms512M -jar Minecraft.jar
But ends on:
Bootstrap (v5)
Current time is Aug 26, 2014 1:41:27 AM
System.getProperty('os.name') == 'Linux'
System.getProperty('os.version') == '3.4.90'
System.getProperty('os.arch') == 'arm'
System.getProperty('java.version') == '1.7.0_65'
System.getProperty('java.vendor') == 'Oracle Corporation'
System.getProperty('sun.arch.data.model') == '32'

Looking for update
Downloading: https://s3.amazonaws.com/Minecra ... /launcher.pack.lzma
Didn't find an update in time.
Reversing LZMA on /home/myuser/.minecraft/launcher.pack.lzma to /home/myuser/.minecraft/launcher.pack
Got reply in: 1880ms
No update found.
Unpacking /home/myuser/.minecraft/launcher.pack to /home/myuser/.minecraft/launcher.jar
Cleaning up /home/myuser/.minecraft/launcher.pack
Starting launcher.

Edited by SebastianM at Tue Nov 11, 2014 14:08
TooMeeK replied at Mon Aug 25, 2014 11:48
For me, Minecraft Lancher starts on Ubuntu 14.04.1 LTS..
Here's short how-to:

i have testet the minecraft server, but it ends with an error:

ISPLAY=:0 /usr/lib/jvm/java-1.6.0-openjdk-armhf/jre/bin/java -Xmx1024M -Xms512M -jar minecraft_server.1.8.jar nogui
# A fatal error has been detected by the Java Runtime Environment:
#  Internal Error (os_linux_zero.cpp:285), pid=19272, tid=3054699632
#  fatal error: caught unhandled signal 11
# JRE version: 6.0_32-b32
# Java VM: OpenJDK Zero VM (23.25-b01 mixed mode linux-arm )
# Core dump written. Default location: /media/usbkey/minecraft/core or core.19272
# An error report file with more information is saved as:
# /media/usbkey/minecraft/hs_err_pid19272.log
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla

it is possible to run minecraft-server on the bpi?
I am using debian wheezy

EDIT: Okay this one runs very well on BPI: https://github.com/mc-server/MCServer

EDIT: original minecraft_server.jar runs fuster then mcserver with sun-java!!! No lag anymore

Edited by Avadrus at Thu Jan 29, 2015 11:54

first of all, thanks for your contributions. I tried to get the original minecraft_server.jar running on my Pi yesterday, but it doesn't really seem to work. The server starts as usual, but keeps reporting the error "Can't Keep up. Did the System time Change or is the Server overloaded".
Do you have any idea what I'm doing wrong? When I check the Task Manager of the System, the Server only consumes about half of the RAM when running in idle mode, and even less CPU power (about 20%). What am I doing wrong? Theoretically, there should be enough power to run it, right? I'm using Raspbian on my Pi with an 40 Mb/s Hyperspeed SD Card with 32 Gigabytes.
Btw...which Settings did you use?
Greeting and thanks for any help

Edited by SeaZz at Wed Jun 10, 2015 08:35
Avadrus replied at Thu Jan 29, 2015 11:18
first of all, thanks for your contributions. I tried to get the original minecraft_server.jar ru ...

Well, that is completely normal. The processor isn't fast enough for the server. I tried starting my public server (1.7.10 with plugins) and it took about 10 MINUTES to load, and the server was lagging (i expected this to happen). So... You can run a simple lan server without plugins which doesn't "eat" the resources of your pi and expect a little lag, it's normal.
The cpu usage is also normal try logging in your server and monitor the usage. It should propably go up to 100 % . As i said it's normal. It is just the Cpu which is a bit too slow for the server needs.

You have to log in before you can reply Login | Sign Up

Points Rules