29 14636
From several weeks ago i tried to turn on tft lcd by fbtft drivers but failed.
Anyone trying this?
I confirmed that the spi is working by testing mcp3008 adc on the raspbian image.
I am using hy28b and waveshare22, each are 2.8in and 2.2in tft lcds for raspberrypi.
Both fbtft drivers use 2 spi devices, one is for tft lcd and the other for touch controller,
and 2 or 3 gpio ports for reset, dc, led, etc.
At first I compiled kernel and fbtft driver modules and installed on bananapi.
After rebooting, I did insmod spi-sun7i, fbtft, fbtft_device modules.
Then I tried to start X window through the following command as you know.
$ FRAMEBUFFER=/dev/fb2 startx
But the screen was still blank, no change. Both devices failed. :-(

Related threads

Hi !
I own some hy28b TFT touch monitors and use them with notro fbtft drivers on Raspberry Pi.
Like you, I could also confirm SPI works on the Banana, but I couldn't succeed with the LCD.
I also found this tutorial :
But the sunxi toolchain couldn't install on my Linux computer. So, I'm stuck.

Reply 1# aquilegia

   Try on new Raspbian 3.1

Earler version has a bug, and don't work property on SPI...

Reply 2# HWL_Stouf

Try to install the sunxi-tools on bananapi directly. The build process is so simple.On Bananapi:
$ git clone
$ cd sunxi-tools
$ make
$ ./bin2fex /boot/bananapi/script.bin > script.fex

I confirm that it's possible with this SoC (i wrote the blog post on ( ... -sur-un-olimex-a10/ )).

I advice you to use a ubuntu 12.04 or something "old but stable" to build your system (for your toolchain issues)

Reply 3# sylwek2k
Reply 5# sid

I tried on raspbian v 3.1, but resulted in failure.
Then I also had tried to build kernel and drivers on ubuntu 12.04, but same result too.
I think olinuxino, which uses A10 cpu, has not same core with bananapi's A20.
Moreover bananapi's spi kernel driver is spi-sun7i.ko made by lemaker team, but olinuxino or cubieboard may use a different driver as spi-sunxi.ko.
During insertion of driver modules, the fbtft drivers and GPIO ports for reset, dc, led were well recognized.
After trial  I compared the log messages from dmesg to raspberrypi's. Almost SAME! :-(

Anyway, thank you for the replies.

Many thanks for the details and for testing it.

Reply 1# aquilegia


Post Last Edited by aquilegia at 2014-9-12 21:31

Reply 8# tony_zhang

Wow, Great! Actually today I also succeeded to turn on the lcd with comment of the fbtft developer, notro.

The solution is to load the driver with dma disabled before loading fbtft_device. The command is as follows:
$ sudo modprobe fbtft dma=0

However, I still could not load the touchscreen driver ads7846 with the following command.
$ git clone
$ cd ads7846_device
$ sudo make install
$ sudo modprobe ads7846_device pressure_max=255 y_min=300 swap_xy=1 y_max=3750 gpio_pendown=23 x_max=3650 x_min=150 x_plate_ohms=60

The dmesg is as follows:
[  103.590034] ads7846_device: Deleting spi0.1
[  103.630779] ads7846 spi0.1: unable to get regulator: -517
[  103.635623] spi spi0.1: Driver ads7846 requests probe deferral

Do you know what problem is?

Yes. Our engineer huangchenxinyu contacted notro, and discussed with him on the issues 77 thread. We will keep trying to make the touch screen work.

You have to log in before you can reply Login | Sign Up

Points Rules