Discussion

Problem for compiling Wifi dongle MT7601U

9 4927
Hello,

Can someone help me for compile this driver : http://www.touslesdrivers.com/in ... 23&v_code=38831
For lubuntu ?

I've followed this instruction :http://ubuntuforums.org/showthread.php?t=2206873
but when i use the command "make" , the terminal say me that the folder /lib/modules/3.4.90/build don't exist
And it is true !
I've created this folder, and now the compiler say : make[1]: *** No rule to make target `modules'. Stop.

how can i add this folder ? Is it kernel-headers-3.4.90 , and where find it. It isn't in synaptic package ...

Thx for your help
https://github.com/LeMaker   Source code on github

Reply 1# Beetlejuice

I think this driver is made available by VoiceShen
http://forum.lemaker.org/1736-1-1-baidu_wifi_on_bananapi.html

you could test it...

Post Last Edited by Beetlejuice at 2014-8-18 03:09

Thx a lot, i'll try this one !

EDIT :
No work
I get this error with the command :
insmod mt7601Usta.ko

insmod: ERROR: could not insert module mt7601Usta.ko: Invalid module format

have you copied the provided kernel "uImage" and replaced your current kernel with it?
you may try that.

Or Else

copy the provided .ko file to /lib/modules/3.4.xxx/kernel/drivers/net/wireless/
then run "sudo depmod -a" from a terminal
then run "sudo modprobe -f mt7601Usta"

also post any relevent dmesg output here.

Hello,
no i haven't copied the file uImage, i don't know how to use it ...

the first partition on your sdcard contains the kernel 'uImage'....you need to replace this with the provided uImage(just rename the one in sdcard and then copy over the downloaded one)

If you do not want to go this route please try the 2nd option I mentioned earlier.

Post Last Edited by Beetlejuice at 2014-8-19 10:49

Hello , thx for your help.
But it still not work . I've tried both solutions are they work without error.
The Uimage provided contain the kernel 3.4.90+
I would like to compile directly with the sources gived on a cdrom with the wifi dongle, but i've always the error : /lib/modules/3.4.90/build don't exist
This folder must contain the modules's buid rules if i understand well but i don't know how to get it .
tony_zhang gave me this link :
https://github.com/LeMaker   Source code on github
must i compile all ?
Sorry for all those questions , i'm really lost lol.

A good thing, i've installed Xvnc server a start this afternoon and it work very well
so i can use my BPI without screen,keyboard, and mouse . vnc is active at log screen .
I need all this because my BPI will be the brain of my robot and will control an arduino for this .

FM rbarua has done it already...you could visit the other thread and continue there.

Thx you, i'll read his post

You have to log in before you can reply Login | Sign Up

Points Rules