Interfacing

SPI Module not found

5 8999
Bonie  
Hi there!
Sorry my english is bad.
I want to use the SPI port of banana, as well as the Raspberry.
But even when booting the error message FATAL: module spi-bcm2708 not found.
I use Raspbian_For_BananaPi_v3_1.
Can you help me?
With best regards
bonie
use "raspi-config" to turn on SPI

Reply 1# Bonie

Please pay attention: spi driver in A20 is not the same as in BCM2835. Please use:
  1. sudo modprobe spi-sun7i
Copy the Code

to load the spi driver.

Bonie  
Hallo Tony!
Thank you very much, now he has found the module.
now I want it to work with Python.
In addition I have done the following:

sudo echo "spi_bcm2708" >> "/ etc / modules"

worked, then a test program is loaded:

wget http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git\;a=blob_plain\;f=Documentation/spi/spidev_test.c O spidev_test

worked, this translated as:

  gcc spidev_test.c

worked,

sudo ./a.out

Test works, then

sudo echo "KERNEL == \" spidev0 \. [0-9] * \ ", GROUP = \" spi \ "" >> /etc/udev/rules.d/10-local.rules

worked,

sudo groupadd spi

worked,

usermod-G -a spi <user-name>

worked,

sudo apt-get install python-dev-y

worked,

python setup.py build

worked,

python setup.py install

worked.
But if I now run my Python program, then comes the error:
....., Line 4, in <module>
import spi
import error: No module named spi

Please help me.
With best regards
bonie

hodoors  
Note: The author has been banned or deleted.

It is a pleasure for me to be a part of this forum and it always talks about the important topics and get a different essay writing order  for users. Thanks for this nice post.

You have to log in before you can reply Login | Sign Up

Points Rules