XBMC and 1080p

26 15457
For anybody that wants to get XBMC running in true 1080p mode instead of the unscaled 720p mode I thinks its currently running in I have found that if you open the SD card image file a program called dragonface (http://infoofandroids.blogspot.c ... t-version-v212.html) and make some updates to the system1.lhs and build.prop files and then save and load this image back onto your SD card it fixes this issue.

system1.lhs updates (accessed from the System configuration button on the "Advanced Setting" tab in dragonface)
update "screen0_output_mode" from 5 to 10
update "screen1_output_mode" from 4 to 9
update "fb0_pixel_sequence" and "fb1_pixel_sequence" from 0 to 2 (I updated this setting based on the description of these setting as this seemed correct to me but i have not done any in depth testing to see what difference this has actually made)

insert "ro.sf.lcd_density=231" without quotes, if you don’t insert this line everything on screen in very small as the default density is 160 according to some density change apps i downloaded




Post Last Edited by Sebster at 2014-9-18 10:04

Post Last Edited by Sebster at 2014-8-25 12:02


I think it is more easy, just do go into "Settings">"Display">"Video Output Mode" and change it to whatever you want.  
e.g  1080p 60Hz, 1080p 50Hz , 720p 60Hz or whatever

!! You need an good Power Supply (at least 1A)! my BPi shut down after a few minutes during a 1080p Video because of too less Power.

Reply 2# Sebster

   Dear Sebster,

Data79 has right. If you change only in the Android Display settings that will only 720p with upscale, no real 1080p. You can try it. Change in Android->Settings->Display and after start xbmc and look the systeminfo, you will see the real resolution is only 720P.

Try it.

The solution flash the kernel to real 1080p or change the parameters as Data79....

Best regards:peetr04

Post Last Edited by Sebster at 2014-8-25 11:54

Reply 3# peetr04

Hello peetr04!

Yes you're right!
I've tried it this afternoon and had not the time to delete my post yet...

But I have another question:
When you're working out XBMC running in FULL HD, how does this has an impact on the fps..?
I mean, watching a 720p Movie is possible yes, but when xbmc starts in FULL HD the Mali GPU will getting to it's limit... Doesnt it?

And sorry for my bad englisch, I#m 16 and from Germany

Edited by Playsitloud at Wed Nov 19, 2014 20:25

I cannot follow these instructions. every time I try to burn the image phoenix card burner crashes. I tried different computers same results. I am using a USB card reader to burn the image but when it gets to the part where it is "burning data" it fails with a critical error every-time. anyone have a clue why that might be?

I might also add that I can successfully burn the image off this site but not with these changes suggested.

Playsitloud replied at Wed Nov 19, 2014 22:07
I cannot follow these instructions. every time I try to burn the image phoenix card burner crashes.  ...

Go in Windows device manager, and change your card reader policy from "Optimize for quick removal" to "Optimize for performance".

Since this action, I didn't had anymore this error after the data part.

Hey guys,

can u list working versions and working android versions ?
I tried android 4.4 Beta 1 direct from Download and installed first, android 4.2 direct from download with DragonFace 2.1.2 and 2.1.0.
Everytime  i get the same error: "DragonFace: Firmware does not support the tools to modify, make sure that the firmare version: OK"

Tried with run as admin aswell, i use Win8.1 x64.
Or can so upload a fixed version of android 4.4 beta1 to burn it to SDCard with Win32 or Phoenix?

Hi, I am in the same configuration that you are, so made lot of tentative before going to the conclusion: DragonFace does not work on Win 8.1.

I had to make a local virtual machine based on Win 7 to fix the issue.

Edited by invalid at Sat Nov 29, 2014 09:31

Tx for dat info

Now i used another PC running Win7 x64 and it doenst work either. Did you use 32 bit OS ?
Maybe there is the Problem.

Does anybody have a link to a website ?

Edited by dlanor at Sun Nov 30, 2014 03:36
invalid replied at Sat Nov 29, 2014 08:44 Now i used another PC running Win7 x64 and it doenst work either. Did you use 32 bit OS ?
Maybe there is the Problem.

I use Win7pro_x64 myself, as the main OS of my main computer, and this works fine for use with both the DragonFace and the PhoenixCard programs as described in this forum. So it's not the OS which is the problem with that Win7x64 computer but something else, possibly its card reader/writer. Several people have had problems with built-in card interfaces, and have then solved those problems by connecting an external card reader/writer by USB. This is not always the case though, as I use an internal multi-card interface that came built into my main computer. Even so, it's something worth trying.

Best regards: dlanor

You have to log in before you can reply Login | Sign Up

Points Rules