XBMC and 1080p

27 14824
Hi, I have the same problem. Could anybody upload to somewhere a modified image? I will really appreciate it.

dlanor  
Edited by dlanor at Tue Dec 2, 2014 04:40
spadesbond replied at Sun Nov 30, 2014 09:08
Hi, I have the same problem. Could anybody upload to somewhere a modified image? I will really appre ...


Since there is nothing wrong with the image, there is no modification we can do that will make it work for you.
If you can't flash the image such that it works correctly, then something goes wrong with the flashing process.

The most common problems are an incompatible OS (eg: Windows 8 or 8.1 or 10), or an incompatible SD card writer.

Another cause for problems is if you don't follow the correct procedure in using the PhoenixCard program to flash the card.

I've posted this before, but perhaps that post has 'drowned' it its thread by now... So I may as well do it again. ;)

1: Insert the SD card in the card writer (I assume that was either built-in, or at least already connected to the PC).
2: Check the drive letter assigned for the card by Windows. (If none, format the card so it gets a drive letter.)
3: Launch the PhoenixCard program.
4: In PhoenixCard's selection box labeled 'disk', click the arrow to open a dropdown menu where you select the drive letter noted in step 2 above.
5: Click the button labeled "Img File" to open the file selector where you choose the Android image file to be used.
6: In the 'Write Mode' rectangle, click the selection for "Startup!".  This shows a confirmation popup that you close by clicking OK.
7: In the row of 5 buttons, click the button labeled "Format to Normal". This shows a popup asking if the drive letter is correct, proceed by clicking Yes.
8: Await completion of the format, as shown not only in the text output field, but also with a new popup box. Proceed to next step only AFTER that popup.
9: In the same row of 5 buttons, click the button labeled "Burn". Again you get a popup to confirm drive letter, proceed by clicking Yes.
10: Await completion of the burn. The text field will show completion of several partitions on the card. It is not really complete until you see the text "Burn End. . ."
11: In the row of 5 buttons, click the one labeled "Exit" to leave PhoenixCard
12: In the 'system tray' area of the Windows taskbar, use the gadget for save removal of the SD card. (ensures all write buffers are definitely flushed)
13: Remove the SD card from the card reader, as it is now ready for use in the Banana Pi.

Btw: Some people think that the 'Format to Normal' command is redundant, as the 'Burn' command also starts with a formatting procedure.
But I think these are different types of formatting. The 'Format to Normal' is really a cleaning out of the partition tables, to start with a 'clean slate'.
People who skip that part of the procedure often run into problems when trying to boot their cards in the BPi.

Edit:
Ooops! I forgot the most important step of all, where you select the image file to be used. I'm sure everyone realized it already, but I still have to add it to the list. (inserted as #5)

Best regards: dlanor

dlanor replied at Sun Nov 30, 2014 12:04
Since there is nothing wrong with the image, there is no modification we can do that will make it  ...

Burning is working for me (in a virtualized XP). I would like to use BPI in 1080P as data79 described. But when I open the image file in DragonFace it says:
firmware does not support the tools to modify, make sure that the firmware version

I have just soleved the problem: I upgraded DragonFace to v2.2.0 and it successfully open the img file.

dlanor  
Just so you know: DragonFace versions above v2.1.2 cause failures for most people.
Those who have updated from v2.1.2 to those higher versions have often been forced to revert to v2.1.2 again,
to make DragonFace work right with our images.

I use v2.1.2 myself and have used it for dozens of modified images, without any single failure.
So I find it very surprising that v2.1.2 fails for you while a newer version works.
This is the opposite of what everyone else has reported.

Best regards: dlanor

spadesbond replied at Mon Dec 1, 2014 05:25
Burning is working for me (in a virtualized XP). I would like to use BPI in 1080P as data79 descri ...

Unfortunately I was happy too soon I can modify the img as data79 described, but when I burn this image with PhoenixCard it crashed some minute later. The original img successfully burned, therfore the modified img will be corrupt.
I think, I give up...
dlanor, thanks your help

dlanor  
I'm sorry that you're giving up, but hopefully you can find some useful image among the others available on the site, now that other users have been able to make such modifications and also rebuild the entire Android system from source. I know that some of the images available are modified to give 1080p, though you will have to make a change of the display settings after boot to complete the change (once only). Perhaps one of those images will burn correctly even with your setup.

However, I think it was a mistake for you to switch to the newer DragonFace version, since that is what has given most people problems with crashing images.
Since version 2.1.2 is what works best for everyone else, I suspect that you too need to be using that version, though perhaps on different hardware from the PC+card_writer it failed to use correctly earlier.

Best regards: dlanor

ChrisP  
Edited by ChrisP at Tue Dec 2, 2014 14:34

Yes DragonFace 2.2.0 seems to have some issues, stay on DF 2.1.2.

I'm a bit confused by your message, when you talk about burning on virtual XP, you are talking about modification based on DragonFace or burning image content on sdcard ?

Regarding the burning process, meaning putting the image on the sdcard, you can use Phoenixcard on Win 8.1 64 bits (I do that on this OS), but be sure to modify removal  policy from Quick removal to Better performance of your SD card reader and to disconnect the sdcard using the notification icon.

DragonFace does not work on Windows 8/8.1. You get the message like image does not support system tool at 70% loading, that does not appear when loading on image on Windows 7. Using DF on a XP or Seven VM is fine for that, that's also what I do.

liab  
My problems with phoenix 3.1.0 and dragenface 2.2.0 on win7 are so:

If I load a image in dragonface and save it even without any changes phoenix will stop in the middle of
the bar with an error. But it doesn't matter the image still works!

The error is preventable by doing this in sysconfig.lhs (last partition) before save it in dragonface:

;------------------------------>nandl, UDISK
;[partition]
;    name         = UDISK
;    downloadfile = "diskfs.fex"
;    verify       = 0

invalid  
So some News for you:

I tried DragonFace 2.10, 2.12 and 2.20 on Win 8.1 x64 (obviously no success), Win 7 x64 (neither) and Win 7 x86 and still no success.
I tested the Android V2 Download from lemaker.org with Android 4.2 and the Android 4.4 beta 1 Release aswell.
Everytime I get the same error:
DragonFace: Firmware does not support the tools to modify, make sure that the firmare version: OK

As I didnt use any Cardreader so far, I dont get why it doens't work.
In depression I installed the Image with Phoenixcard which worked great, booted it once and then wrote an image with Win32Imager. Not expecting to work I tried to load that img file with Dragonface, also no success. I downloaded the image files several times from different sources, no success at all.

So can so with a working version just create a normal Android 4.2 Image with 1080p fix and upload it ?
Then I can download it and burn it with Phoenixcard.

Did I miss any part of the fix or why does it not work ?

mattrix  
Edited by mattrix at Tue Dec 2, 2014 16:25

I use on Windows 7 Pro x64

DragonFace 2.1.2
https://mega.co.nz/#!vY5jgQbL!av ... 8Ar3vsvzKQ4F-GlCGS0

PhoenixCard 3.0.9
https://mega.co.nz/#!zFYkTJwa!U9 ... cqNNX2aLeuaNAEj8d5M

Never have any problems.

Ignore messages to update when running

You have to log in before you can reply Login | Sign Up

Points Rules