Bananian

Headers?

8 3582
Where can we find headers or instructions on creating headers?
Please create the headers from the source code!
https://github.com/LeMaker

Seconded! We really need headers. How would one be able to MAKE driver support (rt5572 in my case) on once own, LE-MAKER?

Btw, the answer of tony_zhang -- as of 4th of January 2015 -- leads to 3.4.103 kernel details on githup. If you are on bananian 4.11 you need 3.4.104+ headers -- at the moment. Please allow us to compile our ow drivers. This necessitates recent headers, no matter what.

Without proper resources headers, documentation, source code the banana pi is a trap, feels like a prison.

@tony_zhang: letting people "create the headers from the source code" is not in the reach of most users. Please help normal users to get their drivers by setting up a process that provide appropriate headers for all your releases.

https://github.com/Bananian/linux-bananapi
the last commit in Bananian 14.11.x is 56911ecbe2ffa5d07f5748ba49ddeb1735b5f30b

Thanks! Would I need to match the header files for compiling my driver to the headers of the commit of the Bananian version at hand or to your last commit at github?

Clone and reset to commit 56911ecbe2ffa5d07f5748ba49ddeb1735b5f30b to get the 14.11.x kernel or compile using the last commit and get the kernel of the upcoming Bananian version.

Thanks! I came to switch to Igor Pečovnik's BPi Debian images (http://www.igorpecovnik.com/2014/09/07/banana-pi-debian-sd-image/) that do provide the headers. I'm trying to compile the driver for the rt5572 chip in the USB WiFi dongle I'm using. However, I was running into make errors (… Entering directory `/usr/include’ … No rule to make target `modules’. Stop… Error 2 …) may be because the Makefiles just cover the 2.4 and 2.6 kernels. Since 3.10 or so RT2800usb should also support the Ralink rt5572 chip, though. Best would be using a stable kernel beyond 3.10 but http://linux-sunxi.org is still sticking to 3.4.x. I did not try jet the development versions sunxi are providing.

Did someone succeed in getting a rt5572 based USB WiFi dongle to running on the BPi?

DrTune  
Same wifi dongle here.

I got the Realtek RT5572 driver to work (compiled and ran) on bananian but not in AP mode (which I wanted) - I had hostapd working with a different (ralink) dongle before but now need a 5.8Ghz AP.
Hostapd doesn't support the RT5572STA driver at all; you need a recent RT2800usb (as you know, 3.10 kernels and up)...  I thought about trying to compile it as a .ko for bananian but life's too short.

To get the RT2800usb that supports it I switched over to Igor's Debian Jesse image (http://www.igorpecovnik.com/2014 ... age/comment-page-1/) which recognized it out of the box ; everything else I use package-wise seems to work fine so far on that distro.  It's been about half an hour and I'm basically back up (because I kept a careful log of all the packages I installed on bananian :-)

So far I see no downsides in going to newer kernel/distro; YMMV. Not tried the SATA yet but Gig-E and usb etc works fine.
I'm running
root@bananapi:~# uname -a
Linux bananapi 4.0.5-bananapi #10 SMP Wed Jun 10 21:50:24 CEST 2015 armv7l GNU/Linux

tkaiser  
DrTune replied at Mon Jun 29, 2015 16:43
So far I see no downsides in going to newer kernel/distro; YMMV. Not tried the SATA yet but Gig-E and usb etc works fine.

No problems to use SATA either. Igor already included some performance tweaks regarding kernel config, but you should check cpufreq settings, and I/O schedulers are also worth a look to get most out of the SATA implementation: http://sunxi.org/SATA#Performance

You have to log in before you can reply Login | Sign Up

Points Rules