Other Projects


53 49183
i have the same problem, i read somewhere about mali driver glitch but i don't know when they'll fix it

Yep, in 1080p, the menu behaves beter, but not perfect, it´s a know issue with mali, on x86, or imx6 processors the menu its normal.

I ha tried to fix it but everithing i tried had given no results.

In Lakkatv github, i´m starting to see some work over the menu, perhaps they make some fixes in a sort time over the display errors on mali gpu´s.

Also, note the openGL provided by Allwiner it´s crapy, for compiling some emulators it already have patches to headers, and in various tries i made to run mupen64plus, i had to do vary hacki workarrounds and patchs to openGLes to, at leas compile it. i cant even tun it due to drivers error...

The real solution will be, receive a well compiled, tested, bug free nice drivers from allwiner(not necesary open source but at least full functional bug-free, like on Rpi). But, i don´t know if someone on Lemaker or another organization using allwiner socs is doing some preasure over Allwinner to get it, the opengl-mali drivers and the VPUdrives of course...

you mean then that's normal?
I've added a ROM (mame) to an usb, but it's difficult to select it because cannot see the menu

Yes it´s normal on Allwiner devices, sorry for this, i use it on a 1080p tv and have less problems, only black background sometimes... but i see the icons...

there's an open source driver for allwinner devices here http://limadriver.org/ but i really have no idea if it would work :/

I've taken a look too to lima drivers. I'm trying to compile it on RetroArch.
BTW with default retroarch compilation I got:
"* failed to open vchiq device"
Has someone an idea?
Here how I've compiled it with details, on libretro forum:



vchiq i think it's a raspi driver

I belive retroarch replaced lima with mali-fbdev driver.

i'll take a look

I've tried to compile 'https://github.com/libretro/RetroArch' with this lakka patch:

https://github.com/lakkatv/Lakka ... ix-mali-fbdev.patch

But I'm getting:

gfx/context/mali_fbdev_ctx.c: In function ‘gfx_ctx_init’:
gfx/context/mali_fbdev_ctx.c:205:4: error: invalid use of undefined type ‘struct mali_native_window’
gfx/context/mali_fbdev_ctx.c:206:4: error: invalid use of undefined type ‘struct mali_native_window’

PS: keep in mind I've applied the patch by hand (and via patch as well), so the line could be not the same as on the automatic patched file. BTW it refers always on:

   native_window.width = vinfo.xres;
   native_window.height = vinfo.yres;

Any ideas?


nope, i have no idea about this. maybe guys from irc can help here
join the lakkatv channel

Post Last Edited by recio.alex at 2014-9-12 10:30

Post Last Edited by recio.alex at 2014-9-12 10:29

if you compiled it previousli, you must have compiled binaries here:


And in the same .install_pkg from the other retroarch packages.


You have to log in before you can reply Login | Sign Up

Points Rules