Other Projects

Lakka.Tv

52 21680
alexandrevicenz replied at Tue Feb 3, 2015 15:06
What do you mean?

Your gamepad doesn't work on Settings, or you can't change settings?


Hallo,

the problem is following:

I go to "Input Options". Then I set "Max Users" to 1 with the cursor keys of my keybord (to make the configuration smaler).
Then I go to "User 1 Device Index", "User 1 Bind All" and "User 1 Bind Defauult All" and see that there is my Gamepad is listed (Logitech Precision...).
Then I go down to "User 1 B button (down)" and see that it is configured to "(Key: a)". According to my understanding i had to change this to a button of my Gamepad, because i think the meaning of "(Key: a)" is the "a"-key of my keybord. So I thought I have to press a Key on this configuration point and then ther will stand something like "recording key" and i have to press the B-button of my gamepad to change this Configuration point. Or I am wrong? I can press every key on keybord but nothing will changed   

NBGabber replied at Thu Feb 5, 2015 03:26
Hallo,

the problem is following:

Do you want to use keyboard or gamepad?

On keybord I use X, Z, A, S, not sure what is what on gamepad. But maybe the bindings of keys are wrong.

If you want to use gamepad, could you run this command?
  1. retroarch-joyconfig -a
Copy the Code
And post the output. Just follow the steps asked when you run this command.

Edited by NBGabber at Thu Feb 12, 2015 00:21
alexandrevicenz replied at Tue Feb 10, 2015 19:08
Do you want to use keyboard or gamepad?

On keybord I use X, Z, A, S, not sure what is what on gam ...


Yesterday I fixed the problem

Yes, alexandrevicenz I wanted to use gampad, and now it works
this command retroarch-joyconfig is the right way but that is only the beginning of a long way to fix it.
I will write down the steps i did't in case that someone how have the same problem read this.
Please forgived me, but i write it down from my mind. I have not the time to test if it is rigth.

First the Problem:
I have read that every time you pluged a Gamepad in your usb port, Lakka.tv read the vendor and product ID, and
compared it with the configuration files  stored in /etc/retroarch-joypad-autoconfig. But there are only a hand
full Configuration files and if VID and PID of your Gamepad thers is not implemented, then you can't controll lakka.tv
with your gamepad. To make a new configfile it is necessary to run retroarch-joyconfig, but there is a second problem.
After retroarch-joyconfig generate the configfile, I recognize that I can't write to the file system. The reasen for this
is, because the compleat linux system is stored in one compressed file stored at the first partition of the SD Card and
is named SYSTEM. This File is squashFS format.

What we need:
A PC or a Banana with Linux system

1. Step
We start Lakka.TV and connect to it via SSH then we plug in the Gamepad.
then we start:
  1. lsusb
Copy the Code
on this output we note the VID and PID of the Gamepad

then we start
  1. retroarch-joyconfig -t 5
Copy the Code
I set (-t 5) as timeot because my Gamepad has not all buttons and so I can wait 5 secend to let it undefined
retroarch-joyconfig starts to asking for every buttton. So follow the instructiond.
After that retroarch-joyconfig put out the configuration to standard output. Make a note of this configuration.

2. Step
Shutdown Lakka.tv and put out the sd card and put it on a PC or banana with Linux (I used OpenSuse)
then mount the sd card
  1. mkdir /tmp/lakka
  2. mount /dev/mmcblk0p2
Copy the Code
then I installed spuashFS

in OpenSuse:
  1. zypper in squashfs
Copy the Code
then
  1. unsquashfs /tmp/lakka/SYSTEM ~/
Copy the Code
then the system will decompressed

then go to
  1. cd ~/root-squash/etc/retroarch-joypad-autoconfig
Copy the Code
then make a copy of anny configurationfile
  1. cp iBuffalo_Classic_Usb_Gamepad.cfg NAMEOFYOURGAMEPAD.cfg
Copy the Code
edit with text editor
  1. nano NAMEOFYOURGAMEPAD.cfg
Copy the Code
Then change the name, the VID and PID (Caution! write as decimal value) and all Buttons and Save.
after this we had to repack it
  1. mksquashfs ~/root-squash ~/SYSTEM -no-xattrs
Copy the Code
then override to sd card
  1. cp ~/SYSTEM /tmp/lakka/SYSTEM
Copy the Code
put the sd card to your banana and boot
thats it!

VasCr  
I have justed tried the Lekka tv on a Banana pi.
Althtough the graphics are super fast for most of the roms i have tried, the controller is not working properly (Logitech Rumblepad 2 ). The repsonse time is slow. Do you have any idea on how to configure this?

Artic  
will they support N64 in the next releases?very nice os btw

I got the latest image from lakka.tv and it works great. Better controller support than android. I have a generic ps controller, a generic N64 controller and a logitech wireless controller. All work great. PS and GBA working great after copying bios across. However, still can't get NES working. Maybe I'm using the wrong bios file???
All in all the latest version of lakka.tv is amazing. I tried the image that was in the original post. It was very glitchy, but it managed to read my sata hd strait away. The new image did not, but it was fine to copy roms across the network.

FANTASTIC JOB!!!!
I love this

hecatae  
hang on,

Lakka is built on top of Openelec, what's to stop us taking the Banana Pi project files from Lakka and adding the to Openelec?

https://github.com/libretro/Lakka/tree/lakka/projects

see above, compared to below:

https://github.com/OpenELEC/OpenELEC.tv/tree/master/projects

SkualO_  
Hi! Sorry I posted on other thread this:


"Hi! My first message, I'm happy to be here.

I use Lakka and work fine, but I can't save my progress. Any solution?

Thanks!"

Now I posted here, because I see this is the main thread. Sorry for my confusion. I hope someone can help me.

cyryllo  
recio.alex replied at Sep 11, 2014 10:13
Hi

All the emulation is done via Retroarch.

I download stable image for Banana Pi but no have mame emulator. Nightly image have mame emulator?

You have to log in before you can reply Login | Sign Up

Points Rules