Trouble

Banana Pi not booting

12 5663
Achelos  
Hello Banna Community,i have a Problem with my Banana Pi its not booting.
When i plug in the usb cable only the red led shines and nothing happens(no video output and nothing else).
I have tested it with diffrent sd cards and diffrent Operating Systems i also tryd to write it from linux and from Windows.
I really need your help because i think i am only to stupid!
ps: I have allready replaced it against it new one(the board)
I hope you can help me!
I suggest to check your Power source (PS), it has to be 5v 2A.
Also check the USB cable, if it is connected to the PS.
Do not power up Banana Pi with a USB cable connected to a PC.

I the hardware is OK include board, sd card, power adaptor, the green led in the board will blink.

mugs500  

peidor  
I am experiencing the same problem: no boot, red light on. tried different cards, I am using a powersource from a WORKING  raspberry install (yes, 2Amps). I have no green light, no network lights, nothing onscreen.

tried two images: raspbian 3.0 & 3.1. Will now try another distro

any suggestions or is the hardware broken? How do I check?

Achelos  
Its now working for me but i had to use another sd card reader!
Mfg Achelos

peidor  
I think I am on to the problem. just booted a Bananian distro from a ZIP archive, unpacked with jzip. worked fine, the BPi boted fine

The files in our download section are all TGZ, in windows they unpack into .TAR files. These TAR files contain two files: 0.fat & 1.img; when I look at some reviews / installation videos it looks like unpacking a tgz's immediately produces an IMG under linux/iOS.

therefore I am now trying to rename the first TAR that comes from the TGZ to .IMG and retry...

will keep you posted. if anyone knows a better way , do let me know. At least I know it's something with the image/card, not the hardware...

pgk  
That actually sounds like it's the two partitions, the FAT one which has the kernel image and the linux root filesystem. Both are needed to work.

I doubt very much it's to do with the OS the resulting of opening a TGZ file, as windows doesn't natively do so, it'll be down to the tool you are using to open it.

I use 7Zip and have just opened the .tgz(a) file from Raspbian 3.1 and I first see the .tar(b) file, then open that and see a .img(c) file and if i then open that I see the files you mention (.fat and .img).

What you need to put on the SD is the .img file I labelled (c) above, not the later one.

peidor  
ok. it worked. apparently Jzip does something different than 7-zip. The latter extracted the correct image. It booted fine, I am now trying to set it up to my purposes

thanks for all the help

Koala  
Hi there,

my Pi does not boot. I already tried using the Arch and the Lubuntu image. In both cases, only the green and the red leds turn on, nothing else happenes. I also cannot mount the sd card on my Ubuntu laptop as I'm told the file system was unknown. I copied the images as followes:
  1. # dd if=/home/sven/Downloads/ArchLinux_For_BananaPi_v2_0.img  of=/dev/mmcblk0p1 bs=4M
  2. 875+0 Datensätze ein
  3. 875+0 Datensätze aus
  4. 3670016000 Bytes (3,7 GB) kopiert, 414,132 s, 8,9 MB/s
Copy the Code

  1. # fdisk -l
  2. Platte /dev/mmcblk0: 7948 MByte, 7948206080 Byte
  3. 81 Köpfe, 10 Sektoren/Spur, 19165 Zylinder, zusammen 15523840 Sektoren
  4. Einheiten = Sektoren von 1 × 512 = 512 Bytes
  5. Sector size (logical/physical): 512 bytes / 512 bytesI
  6. /O size (minimum/optimal): 512 bytes / 512 bytes
  7. Festplattenidentifikation: 0x00022330
  8. Gerät  boot.     Anfang   Ende           Blöcke       Id          System/dev/mmcblk0p1
  9.                        2048    15523839     7760896    c           W95 FAT32 (LBA)
Copy the Code
My sd card is a SanDisk class 10 8GB type. My power supply is a 5V/3A type (verified).

Any suggestions what I am doing wrong here?

You have to log in before you can reply Login | Sign Up

Points Rules