Other OS

BanaNAS OMV

50 20597
minh  
when i type in sudo apt-get upgrade i get this message
E: Could not get lock /var/cache/apt/archives/lock - open (11: Resource temporarily unavailable)
E: Unable to lock directory /var/cache/apt/archives/

Can you please help me. I am unable to install any plugins or update my banana pi with banaNAS 0.2

cyryllo  
try:
  1. rm  /var/cache/apt/archives/lock
Copy the Code
and
  1. sudo apt-get update && sudo apt-get upgrade
Copy the Code

rm2015  
Edited by rm2015 at Sun May 10, 2015 11:29

Hi Cyryllo,
Thank you so much for banaNAS - OMV, i installed it on my bananapi and its amazing. I am using it as a NAS and DLNA server. However I recently bought a a DVB-T2 stick and I wanted to add tvheadend to the list of services. Problem is that the DVB-T2 stick (Geniatech T230 is not detected even though it is supported in linux from kernel 3.19. (kernel in use i believe is 3.4.103) i tried to add support using mediabuid and after following instructions, I get the error below.
  1. Preparing to compile for kernel version 3.4.103
  2. File not found: /lib/modules/3.4.103/build/.config at ./scripts/make_kconfig.pl line 33, <IN> line 4.
  3. Makefile:366: recipe for target 'allyesconfig' failed
  4. make[1]: *** [allyesconfig] Error 2
  5. make[1]: Leaving directory '/root/media_build/v4l'
  6. Makefile:26: recipe for target 'allyesconfig' failed
  7. make: *** [allyesconfig] Error 2
  8. can't select all drivers at ./build line 490.
Copy the Code
Please note that kernel stuff is new territory to me. I really like OMV and i'd like to retain that and just add support for the dvb-t2 stick,
would please help me out.
Thank you

cyryllo  
You can download image Debian Whieezie with 3.19 kernel from http://www.igorpecovnik.com/2014/09/07/banana-pi-debian-sd-image/ and install OMV

rm2015  
Wow, that was fast. Thank you so much. Will try today

Wieczor  
I think I will give up
I have installed it and it disconects webui every minut nothing shows on screen.

loading loading loading

I dont know what is a problem

Wieczor  
Loading...
Wystąpił błąd
communication failure

Looks good but I can't install the miniDLNA plugin. C&P for the error message doesn't work either but this should be the important part:
The following packages have unmet dependencies:
     openmediavault-minidlna : Depends: minidlna (>= 1.0.24)  but it is not going to be installed
E
:
Unable to correct problem, you have held broken packages.

Can anyone tell whether this is this a problem on the side of OMV or BanaNAS, maybe no version of minidlna for ARM?

cyryllo, is there a way i could update BanaNAS to simplenas?

cyryllo  
Simplenas for Banana based on bananian (old version based on Raspbian).
I would recommend a fresh installation. The data on the disk will not lose. However, will have everything set up again in the panel. OMV will recognize you with all the resources and configurations.

It should, however, go on simplenas, because it will be constantly updated

You have to log in before you can reply Login | Sign Up

Points Rules