Bananian

Bananian Linux - 14.09

20 7098

Thanks Nico, for this awesome little distro. I did a clean install yesterday and set up a firewalled fileserver within just 30mins.

I have a question about bananian-config, though:

When I run bananian-config, I get this:
>our current keyboard layout is 'us'. Do you want to change it? (y/n)

When I enter 'y', I see messages that the keyboard layout is being configured and after a few seconds, the script moves on to the question about changing the root password.

Now, when I run bananian-config again, I see that the keyboard layout is still 'us'. So, nothing changed, which didn't really surprise me because there was no prompt to select a keyboard layout or hit some keys to detect the layout.

I'm running Bananian as a headless server, so I dont have a keyboard attached directly but rather access the BPi via ssh. Maybe this is the problem?
If so, it might be nice to add a line like "The keyboard layout can not be changed remotly (e.g. via ssh)."

Anyway, as I'm not really sure whether this constitutes a bug or not, I didn't file a bug in the tracker. But if you think it is, I can do so.

Thanks,

Timo

sammo  
Reply 10# EricaTee


    Hi, I followed this guide.

http://www.raspberrypi.org/forums/viewtopic.php?f=29&t=44177

It tells you why you cannot use /dev/sda1 or UUID as a label to your rootfs if you have more than one usb disks attached.
You will need to modify uEnv.txt.   Mine looks like this with root=

bootargs=console=ttyS0,115200 console=tty0 sunxi_g2d_mem_reserve=0 sunxi_ve_mem_reserve=0 disp.screen0
_output_mode=EDID:1280x720p50 hdmi.audio=EDID:0 console=tty1 root=PARTUUID=5416546C-F4FA-4FC7-B492-8FF
1863196FC rootfstype=ext4 elevator=deadline rootwait

Post Last Edited by EricaTee at 2014-9-19 03:34

Reply 13# sammo


    Thank you Sammo. What about your GUI?

Sorry, i thought you had Graphical UI installed.

Reply 16# sammo

Hi Sammo,

Sorry, i thought you had Graphical UI installed.

hi,
i tried the new Version, but ...
1.)
i didnt get any IP Adress from DHCP ( i use a Gigabit Switch )
dmesg told me Link is up 1000/full and dhp request get an timeout.
If i use Raspery for my banana it will work again.
2.)
i changed the Keyboard Layout to gr
After restart the System i always have us as layout. If i restart the Config Programm i can see the that the german layout is set, but i dont have any german sign. öäü doesnt work. And the Layout still Looks like us.

sammo  
Reply 14# EricaTee

Sorry, There's no GUI for this

Reply 12# silentcreek


   Hi Timo, thanks for reporting. Without having tried, I think you found a bug! I have never tested this without having a keyboard connected.

Reply 16# banana_fred



1.) I did some tests using gbit ethernet and had no problems. Does it work when you set a static ip address?
2.) Did you have a keyboard connected while configuring the layout?

Ok, Nico. I filed a bug report now.

You have to log in before you can reply Login | Sign Up

Points Rules