Bananian

Won't boot after update to 14.09

19 5574
Hi,

I was using Bananian 14.08, I even installed it on my SATA SSD.

I just tried to use bananian update to have the new kernel and i won't boot anymore. Before rebooting I took the time to manually edit uEnv.txt because it was certainly reset by the upgrade (using root=/dev/mmc.... instead of root=/dev/sda1)

I thought it was enough ....
Reply 1# seblucas

Same here, ran the upgrade from 14.08 to 14.09 and the pi did not reboot any longer. I also adjusted the uEnv.txt file to use the UUID, still nothing. So I ran a flash install of 14.09, and still no picture and no proper boot.
I think something is completely wrong with 14.09.

Regards, Joerg.

I can not confirm your problem.

How I tried to reproduce the error:
1.) flash clean Bananian 14.08 to SD card
2.) move root fs to SATA SSD (and change uEnv.txt to boot from sda1)
3.) upgrade to 14.09 using my howto: https://www.bananian.org/upgrade
3.) mount /dev/mmcblk0p1 and edit uEnv.txt (root=/dev/sda1)
4.) shutdown -r now
5.) system boots up without any problems running Bananian 14.09 with the new kernel.

Even Bananian 14.09 kernel with 14.08 userland boots for me but this is not recommended at all. So take care that you change uEnv.txt after the upgrade if your root filesystem is on SATA or USB!

Please describe your steps in detail to let me reproduce your error.

Post Last Edited by seblucas at 2014-9-19 13:01

Well, I moved it elsewhere to check with a monitor and it booted without any problem....

I checked the kernel :

Linux minus 3.4.90+ #1 SMP PREEMPT Fri Sep 12 18:13:45 CEST 2014 armv7l GNU/Linux

I really don't know what happened. I used another USB power supply, maybe the new kernel uses more power while booting .... I'll try again with the original power supply tomorrow (I don't want to risk waking my kids tonight).

Let's assume I don't have the problem anymore. I'll report later if I find something.

Reply 2# mistersixt


Correct me if I am wrong but as far is I know you can't use "root=UUID=.." or "root=LABEL=..." because those parameters are parsed by the initrd ramdisk which doesn't exist on Banana Pi operating systems. See http://mulix.livejournal.com/84768.html

Reply 2# mistersixt

I have just checked the kernel sources for you. You can't use UUID here. Only PARTUUID is supported by the kernel (which is only for disks with GUID Partition Table/GPT)

/*
* Convert a name into device number. We accept the following variants:
*
* 1) device number in hexadecimal represents itself
* 2) /dev/nfs represents Root_NFS (0xff)
* 3) /dev/<disk_name> represents the device number of disk
* 4) /dev/<disk_name><decimal> represents the device number
* of partition - device number of disk plus the partition number
* 5) /dev/<disk_name>p<decimal> - same as the above, that form is
* used when disk name of partitioned disk ends on a digit.
* 6) PARTUUID=00112233-4455-6677-8899-AABBCCDDEEFF representing the
* unique id of a partition if the partition table provides it.
* 7) PARTUUID=<UUID>/PARTNROFF=<int> to select a partition in relation to
* a partition with a known unique id.
*
* If name doesn't have fall into the categories above, we return (0,0).
* block_class is used to check if something is a disk name. If the disk
* name contains slashes, the device name has them replaced with
* bangs.
*/

https://github.com/Bananian/linu ... .4/init/do_mounts.c

I guess I know what was the problem:
You used the USB OTG port for power supply. This is no longer supported in Bananian and you have been warned before upgrading to make sure you use the "DC in" port.

I guess I know what was the problem:
You used the USB OTG port for power supply. This is no longer s ...
Bananian Posted at 2014-9-20 03:01


Damn, you are damn right ;-)  ... I've mixed up the ports ... my bad! Thanks for looking into it anyway!

Kind regards, mistersixt.

I was using the correct µUSB port.

I checked and Bananian 14.09 is using a little more power during boot. Judging from the enhancement it has to be OTG, memory growth (by removing some videocore part), I'll edit the fex and see.

Cubytus  
I have a similar problem here: after formatting and preparing the card as instructed on Bananian's page, I got a kernel panic on boot and it wouldn't go any further. I am using the dedicated power port.

You have to log in before you can reply Login | Sign Up

Points Rules