Discussion

GMAC patch

10 4933
igorpec  
Hello,

I want to use my own sunxi kernel source - is there any patch to get this banana's GMAC working as it suppose to work - stable and at least 50-60mbit (like on Cubietruck) which seems to be the limit for those Socs?
You can get the gmac source code from LeMaker github : https://github.com/LeMaker/linux ... rnet/allwinner/gmac

igorpec  
Post Last Edited by igorpec at 2014-9-25 14:21
You can get the gmac source code from LeMaker github :
tony_zhang Posted at 2014-9-22 21:02


Thank you for saving my time. I succeed with compilation and this is the result:
Banana Debian

I could not communicate with IR sensor. It's not an urgent issue but anyway.

Thanks.

You can follow the http://wiki.lemaker.org/FAQ Q15, the link in the Q15 tell you how to use IR with LIRC. We have tested it in XBMC.

tkaiser  
Igor, I just tried to use your Banana Debian image but I end up with a checksum error:
  1. tk@opennms:/tmp# unzip Banana_Debian_1.0_wheezy.zip
  2. Archive:  Banana_Debian_1.0_wheezy.zip
  3.   inflating: Banana_Debian_1.0_wheezy.md5  
  4.   inflating: Banana_Debian_1.0_wheezy.raw   bad CRC 2cfe2610  (should be 2000f076)
  5.   inflating: imagewriter.exe         
Copy the Code
The MD5 checksum is wrong afterwards: 94acc030137ff624bc33bbd0e142d420 (tested on both a Linux machine and OS X) and I'm not able to boot from a SD-Card I wrote the image to.

Any advices?

igorpec  
Post Last Edited by igorpec at 2014-9-28 01:02

I fixed all (known) problems. It's working now.

tkaiser  
Thanks a bunch, now it works like a charm!

@Tony: You should feature Igors great Debian package in "Banana Pi News": http://www.igorpecovnik.com/2014/09/07/banana-pi-debian-sd-image/

Concerning gmac patch : recent uboot initialise gmac correctly. So patching at kernel level isn't really needed anymore ?

igorpec  
Post Last Edited by igorpec at 2014-10-5 09:50
Concerning gmac patch : recent uboot initialise gmac correctly. So patching at kernel level isn't re ...
dupont-y Posted at 2014-10-5 04:15


Don't know that yet but recent u-boot patch broke booting from EXT4 partition   

ADD: Not sure about this. Seems that I run into troubles somewhere else.

Reply 9# igorpec


    Hum, AFAIK it 'works for me (TM)'...

root@banana-two:~# cat /proc/mounts
rootfs / rootfs rw 0 0
/dev/root / ext4 rw,relatime,data=ordered 0 0
/dev/mmcblk0p2 /boot ext4 rw,relatime,data=ordered 0 0

with "fresh" uboot compiled yesterday.

You have to log in before you can reply Login | Sign Up

Points Rules