Raspbian Image with touchscreensupport?

11 5130
Post Last Edited by Pit2002 at 2014-9-22 01:44


I m a newbee with raspbian. I ve a touchscreen from chalk elec. The screen Works Fine but the touch element doesnt work.
Is there an raspbian Image which Supports the touchscreen without Self complling a Kernel?
Is there a Step by step howto to make the Touchscreen work?

Seems not, but here explains how to do it:

Thanks for your reply.

In the howto is explained that i have to compile the kernel on a separte linux system.
I don´t have another linux system.

Edited by tony_zhang at Nov 09, 2015 22:40

No. You do not need compile the kernel. In the latest Raspbian, the kernel includes the essential driver. Also see here:
http://forum.lemaker.org/forum.p ... ght=touch%2Bdisplay
I also follow this to configure the touch screen

Post Last Edited by Pit2002 at 2014-9-22 13:10

I´ve used the latest raspbian release from the forum. The displays works fine but the touch component doesn´t work.

I can see:
usb 4-1: New USB device found, idVendor=0eef, idProduct=a107
[    3.275503] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    3.287524] usb 4-1: Product: eGalaxTouch EXC7910-1018-13.00.01
[    3.296851] usb 4-1: Manufacturer: eGalax Inc.

I can´t calibrate the screen because the banana detects no touch inputs.

I ve read a lot of about egalax touchscreen and raspbian.
They all Said, that the Touchscreen driver is not ON Board by default....

Here is a short update:
The touchscreen doesn´t work at this time.
I´ve tried different things, but nothing helped.

Nobody here, who used a touchscreen from chalk-elec?

try this

http://www.ebay.com/itm/7-AT070T ... hash=item2ecfe3e7dd

it worked for me in android 4.2.2 and 4.4

Next short update:
The touchscreen doesn´t work.
I´ve connected the screen to a normal debian distribution and it works without doing anything.

I´ve done all of the things above but with the actual image of raspbian, the screen doesn´t work.
If someone have an image which works perfectly with an chalk-elec screen an banana pi please post it.

Edited by Pit2002 at Thu Oct 15, 2015 13:14


someone here in this forum, who connects successfully a chalk-elec screen to the banana pi?
The problem still exists.
I´ve connected the screen to an raspberry pi 2 with raspbian image and the touchscreen works!!
Now i´ve installed the latest raspbian image from this site on my banana pi but the touchscreen doesn´t work. What is the difference between the image for raspberry and the banana pi?

Ok. I´ve found the solution for my problem.
I´ve recompile the latest bananian kernel. I´ve included uInput in the new kernel. Additionally i´ve installed the ARMhf driver from eGalax.
Now the screen works well.

You have to log in before you can reply Login | Sign Up

Points Rules