Discussion

Installing mali r3p2 kernel drivers into LeMaker kernel 3.4

29 16227
kevindt  
Looking at dmesg, it seems to be running two cores

  1. [   13.540494] Mali<2>: Mali MMU: Creating Mali MMU: Mali_GP_MMU
  2. [   13.550666] Mali<2>: Mali GP: Creating Mali GP core: Mali_GP
  3. [   13.560663] Mali<2>: Mali MMU: Creating Mali MMU: Mali_PP0_MMU
  4. [   13.571008] Mali<2>: Mali PP: Creating Mali PP core: Mali_PP0
  5. [   13.581186] Mali<2>: Mali PP: Base address of PP core: 0x1c48000
  6. [   13.591884] Mali<2>: Mali MMU: Creating Mali MMU: Mali_PP1_MMU
  7. [   13.602236] Mali<2>: Mali PP: Creating Mali PP core: Mali_PP1
  8. [   13.612414] Mali<2>: Mali PP: Base address of PP core: 0x1c4a000
  9. [   13.623113] Mali<2>: 2+0 PP cores initialized
Copy the Code

Reply 10# kevindt


  Thank you, will compare my notes with the script above and report back later.

Think all may be ok, although the version is being reported as r3p2-01rel1 if you look at /sunxi-mali/version/version.c it would appear that r3p2-01rel1 will also be reported for r3p2-01rel2...

static struct {
        int version;
        const char *compat;
} version_compat[] = {
        {6, "UNSUPPORTED"}, /* r2p0 and r2p1-rel0 */
        {7, "UNSUPPORTED"}, /* r2p1-rel1 */
        {8, "r2p2"},
        {9, "r2p3"},
        {10, "r2p4"},
        {14, "r3p0"},
        {17, "r3p1"},
        {19, "r3p2"},
        {20, "r3p2-01rel1"}, /* and r3p2-01rel2 */
        {23, "r3p2-01rel3"},

        {0, NULL},
};

Looked at dmesg and my system also reports

Mali<2>: 2+0 PP cores initialized

There is a problem however when running the "test" the triangle shows on screen but it seems to lock up the BPI console session.

Will proceed with my next steps (Trying to get QT working with framebuffer) and see how I get on.

A copy of your experimental script would be much appreciated.

Tried starting again from scratch, now I cant get the 2nd patch to apply!

root@ubuntu:~/linux-bananapi# git apply 0003-Sunxi-adaptation-for-mali-r3p2-01rel2-kernel-module.patch
error: patch failed: drivers/video/Kconfig:25
error: drivers/video/Kconfig: patch does not apply
root@ubuntu:~/linux-bananapi#

Though looking at the git repo the last commit was 6 days ago.

Reply 14# deales82

Ok, so I took a look at my previous attempt from a few days ago checked what commit I was at and it reported 41b73cecfd5c6f97233047fc56b9d60d1dc6fb5e, on my second attempt which I have done today the commit is showing as 090b16927f028ce73a2cde2c05df4a78d7294c1a and the 2nd patch does not apply correctly.

I have fixed the issue on my latest attempt by doing git checkout 41b73cecfd5c6f97233047fc56b9d60d1dc6fb5e, which then lets me apply both patches without issue.

I am still puzzled though as to what is going on because looking at github...

090b16927f028ce73a2cde2c05df4a78d7294c1a - Committed 23rd September
41b73cecfd5c6f97233047fc56b9d60d1dc6fb5e - Committed 26th August.

You only posted your patches 4 days ago so surely I should have been getting 090b16927f0... from the start? I was git cloning onto a fresh VM with git clone https://github.com/LeMaker/linux-bananapi.git

Confused!

kevindt  
Reply 15# deales82

The patch creation preceded the 23rd by a few days, so I can see how the latest commit might break something. However, you would have thought that your first clone would not have worked!  Strange.  I'm still patching against a clone from before the 23rd, and it works perfectly, of course.
If I get time, I'll try to generate a patch against this new commit - but with the existing patches anyone else can do the same as you have, and drop back to the prior version before the 23 Sept. commit.

The compiled system runs quite nicely with mplayer, even with the system running x and lxde.  CPU load rarely touches 20% on my test full-HD H264 clips (big buck bunny etc) and mostly cruises at 10-20%.  With acceleration turned off, mplayer tops out the CPU at 100% and throws errors.

Kevin

kevindt  
Reply 15# deales82
Here are the revised git patches for applying to the LeMaker kernel after the commit for tbtft has been applied.

https://dl.dropboxusercontent.com/u/23861053/New%20patches%20for%20script%20after%20fbtft.zip

Thinking a little more, that commit may have been done on the local repository on the 23rd, but not pushed to github until later.

Kevin.

I will create a new kernel branch for this

kevindt  
Reply 18# tony_zhang

Thank you, Tony

Kevin.

Reply 17# kevindt


Thank You!!! Will give it a whirl in a bit.

You have to log in before you can reply Login | Sign Up

Points Rules