Discussion

Installing mali r3p2 kernel drivers into LeMaker kernel 3.4

29 16226
Reply 17# kevindt

Just tested, and the patches apply without error on the latest commit

adatxjp  
After I have upgrade the kernel to this version, I can't open XBMC which it could run. The dmesg as follow

[   90.441764] Warning: this sunxi disp driver will see significant redesign.
[   90.453659] Applications using /dev/disp directly will break.
[   90.465942] For more information visit: http://linux-sunxi.org/Sunxi_disp_driver
[   90.479650] disp: process 2073 (xbmc.bin) has skipped the version handshake.
[   90.489874] [DISP] layer released: 0,101
[   90.499408] [DISP] released layer not allocated in this session: 0,101
[   90.509015] [DISP] layer released: 0,102
[   90.518541] [DISP] released layer not allocated in this session: 0,102
[   90.532930] [DISP] layer released: 0,103
[   90.542417] [DISP] released layer not allocated in this session: 0,103
[   90.552072] [DISP] layer allocated: 0,101
[   90.559131] [DISP] layer released: 0,101
[   90.566133] [DISP] layer allocated: 0,101
[   90.587857] UMP<2>: New session opened
[   90.590580] Mali<2>: Session started
[   90.593019] Mali<2>: No handler for ioctl 0xC0048205 0xBEBDE0A4
[   90.597951] Mali<2>: Session has ended
[   92.779744] [DISP] layer allocated at close: 0,101
[   92.785461] UMP<2>: Session closed

can anyone help me ?

adatxjp replied at Sat Oct 4, 2014 18:19
After I have upgrade the kernel to this version, I can't open XBMC which it could run. The dmesg as  ...

i've the same problem,
running kernel 3.4.103+ from github linux-bananapi
kernel patched for mali r3p2-01rel2
sunxi-mali installed
xmbc gotham a10 recompiled
xmbc hangs on startup with a message like yours

i've read about r4p0 with libvdpau but without framebuffer,
any news about?

Mediamind

Edited by SwordMaster at Thu Jan 22, 2015 14:47

Hi! Is there any possibility to build 3.4.103 kernel with r3p2 mali driver? As far as I understood that the patches from this thread are useless.

Edited by SwordMaster at Sat Jan 24, 2015 08:25

Finally installed r3p2 along with kernel 3.4.103+ and r3p2 modules, but I don't see any performance improvements. glmark2-es2 gives all the same 75 score points as with r3p0. Probably the second pixel processor doesn't work.

alient  
its my first post so hi to everyone

im just curious why are you using r3p2 insteed of latest r5p0 drivers ?

alient replied at Tue Jan 27, 2015 03:57
its my first post so hi to everyone

im just curious why are you using r3p2 insteed of latest r5p ...

Good question ;)

vizit_f  
kevindt replied at Mon Sep 29, 2014 16:16
Reply 15# deales82

The patch creation preceded the 23rd by a few days, so I can see how the latest ...

Hello! I have a problem with mplaer.
I run mplaer remotely from the command line. mplaer does not play the next track without pressing enter. Maybe you know how to make the next track will automatically play? Tell me, please. Thanks!

vba  
status? dead end?

So... Anything new? Ideally raspbian 1080p

You have to log in before you can reply Login | Sign Up

Points Rules