[SOLVED!!] Cannot even get 4.4 to boot

9 4601
Post Last Edited by roses2at at 2014-10-2 07:35

Thread moved here from Post #127 http://forum.lemaker.org/viewthread.php?tid=1482&extra=&page=13



I cannot even get my 4.4 card to boot up at all, either via AV video or HDMI (the latter via a DVI adaptor) and with two Power Supplies giving a total of 3.0 Amps. Nada, zilch, nothing, not even the A20 boot logo!! Is the default visual output for this image the former or the latter?


To ensure success, are there any tweaks I could be doing to the image either:
1) with DragonFace before burning with PhoenixCard


2) with the files as they appear on the SD card using Paragon ExtFS?
Chris P said:

Regarding the 4.4, I've read that there is probably a battery level check at initial boot sequence. So you have to push the power button several seconds. It works sometime, and soemtime not.

roses2at said:

What you've read is (with respect) not much use to me, as I've also read that particular thing and hundreds of other things too.

To be honest, what I need is someone who has successfully booted up this image to give me some guidance and practical advice and exact instructions as to what s/he did or didn't do.

Nevertheless, I reburned the image on a card (actually two different makes but both Class 10 8GB) and followed your advice, first with only one PSU plugged in, then both, then swapped them around, pressed the Power button multiple times, and also tried the Reset button.

What you didn't specify was whether you think it should be a long push (ie similar to a hard reset, approx 5 secs) or a short one (ie a soft reset, about 2-3 secs).

But this instruction you gave me isn't included in the official Read Me file that you can download at the same time as the image from the external website, so it's possibly not that important as I feel sure the developers would have remembered to include it.

ChrisP said:

I just made the test, here is exactly how I did:

1 - Put the sd card on the BPi without PSU.
2 - Plug 2A PSU on alim micro-USB.
3 - Pushed the power button (short one, just 2-3 sec, the red light does not shut down but quickly flickered a bit one or two seconds after I released it.
4 - Wait. It took 20 sec (I measured) for my screen before detecting a video signal on HDMI, and maybe 30 sec more before the video signal showed me something (I didn't measured that).

Yes the 20 sec initial lag is annoying and do not let you easily understand if the device is booting properly.

Tell me if you want additionnal directions.

Post Last Edited by roses2at at 2014-10-1 12:17

roses2at said:

@ Chris P

the 20 sec initial lag is annoying and do not let you easily understand if the device is booting properly.


Thank you for that practical advice.
The key phrase for me in your post was 'initial lag'. I had no idea it would take that long to even get a video signal. Do subsequent boots (2nd and 3rd time) also have that lag?


And in all of this you only needed one 2A PSU into DC In? You have never needed to use another PSU in the OTG port??


But I think your video output is HDMI-HDMI to a HD-ready TV or monitor, yes??


Here is what I did:
Checked the B-Pi boots up Linux images OK using my HDMI-DVI adaptor into monitor.
Booted up Android 4.2 (Sandisk Class 10 8GB) via AV Video into my TV. [Has never worked for me via HDMI because of the known issue with the DVI adaptor. Any changes I've tried to make in sysconfig1.lhs using DragonFace have no effect and cause PhoenixCard to crash when burning new image.]  A20 splash screen, green Android screen and start of 'Android' boot animation all within the first 10 seconds. Takes about a minute to reach main screen. Subsequent boots are less than 30 seconds.
Repeated with mattrix's Stock-Mod image. More or less the same timings.
Repeated all of the above with a different branded card (Class 10, 8GB).


Burned the standard 4.4 image (589MB, version number "wing_k70-eng 4.4 KRT16S 20140807 test-keys" according to DragonFace).
Booted it using AV video.
Waited over a minute every time.
Tried again with your advice regarding the power button. Waited at least 60 secs.
Repeated again using two PSUs.
Repeated again using different SD card.
Repeated all again using HDMI-DVI output.


So I conclude from all this that it's because I do not have a direct HDMI to HDMI connection that it will not work. (And I do not know for sure how to change the settings to use Android via HDMI-DVI or via AV video.)

ChrisP  
Thanks to avoid me to copy paste my previous answers ;)

I confirm I'm just using HDMI-HDMI video connection on a full HD monitor. HDMI-DVI may be a limitation, but I'm surprised that AV is as well.

Post Last Edited by roses2at at 2014-10-1 17:22

Reply 6# ChrisP

Thanks to avoid me to copy paste my previous answers

   You're welcome!! It was only logical to do it like that as I didn't know if you were offline/online or working or busy with other things or even if something like that is important to you. But for me it's necessary so that other thread followers, either currently, in 2 week's or 3 month's or one year's time can follow what's being said. (Some people get angry if you move their posts for them!!!)
I confirm I'm just using HDMI-HDMI video connection on a full HD monitor



Yes, I am becoming more and more convinced that my lack of a direct HDMI-HDMI connection is severely hampering my progress and is the reason for non-successful booting, but buying an HDMI TV or monitor is just not an option for me right now.

Like you, I'm also astounded it doesn't work via AV video, or that it's not just a case of pressing a number key down (like the Raspberry Pi NOOBS does) during bootup to choose which output the user wants.

If I was a developer for any kind of OS image, I think that would be one of the FIRST things I'd consider (surely it cannot be all that hard to program, just a few simple lines of code??), rather than just ASSUMING everyone is using their software with an HD-ready screen.

Post Last Edited by roses2at at 2014-10-2 14:26

[SOLVED!!!]

Well, a friend took pity on me and agreed to lend me his HDMI monitor for a little while (it's a Samsung S22D300, but only VGA and HDMI inputs, no DVI unfortunately).

The interesting thing was I took my Pi and my aforementioned HDMI-DVI adaptor and plugged it in to his normal computer monitor (can't remember make/model) via DVI and 4.2 booted fine. So if you're struggling with the same problem I had, it may not be the adapter cable itself but the monitor (or both of course).


[In case I forgot to mention it, the monitor I was using at the time of Post #1 with this HDMI-DVI adaptor (cable purchased from Amazon) was a Dell 1907FP. This screen works fine with all other connections, e.g. DVI-DVI and VGA-VGA, and even from the HDMI output of my graphics card into the DVI port and also for Linux images on the Pi using the 'suspect' adaptor cable. So that's how I knew it wasn't defective - but it would just not work from the Pi into the monitor for Android images.]

So back at home I plugged in his HDMI-HDMI cable and booted up the Pi with Raspbian and also BerryBoot - OK!! But I sort of expected that for the Linux distros.

Then I booted up a previous image of 4.2 which I know already works works via AV video - and it works excellently via digital - much better colours and sharper definition, etc., etc.

And I was going to write this post without even trying 4.4 as I had sort of given up hope with it, but I thought "Let's give it shot" but without any great expectations (good name for a book - an Android book perhaps).

But you were right ChrisP, it's just a case of being patient cos the time lag before the monitor even receives its first signal is about 20-30 secs, then another 10-20 before the boot animation of flying/orbiting coloured balls, and finally to the gaudy yellow Banana Pi main screen. (That will be changed soon!) Why is it not possible for the developers to put in the first few lines of code an image of some sort onto the screen???

Then a lot of messing about going through the setup, with many messages saying 'XXX isn't responding - Wait or Cancel?' which seems to indicate the SoC processor is having to work really hard to do all the set up procedures in the background.

The only hiccup was wired internet didn't work immediately (haven't tried WiFi as there's no point as the ReadMe file says it isn't working in this build yet) but it was just a case of unchecking it and checking it again in Settings>>>More>>>Ethernet.

Subsequent boots were quicker although the update feature in Apps returned an error.

And all this with only one PSU (2 amps) and none of the Power switch short pushes as mentioned in Post #2 above.

So I'm a happy camper and am now off to setup my Play Store account and install some useful apps and explore 4.4 a bit more (that rhymes 3 times!!! - and that does twice!!!!).

Thx y'all

Post Last Edited by roses2at at 2014-10-3 10:14

Reply 6# ChrisP

HDMI-DVI may be a limitation, but I'm surprised that AV is as well.

   
Why would HDMI-DVI be a limitation, do you think? Isn't it more likely that if you have a new adapter cable but an old monitor with a DVI input (as in my case), that you would suspect the screen is at fault for not processing the signal correctly? Because it was designed/built at a time when perhaps the HDMI concept was unheard of or not fully developed and therefore HDMI-DVI adapters were also unknown.

The reason I ask is like I said, I did try my cable into the DVI port of another newer monitor and 4.2 booted OK. I did try 4.4 but I think I didn't know or fully understand about the time lag thing and I wasn't patient enough with it.

Now I've had a bit of time to mull it over, I think the chances of 4.4 working via AV are very slim. I was frankly very surprised to get a picture on my old TV from 4.2 but I was so annoyed that it wouldn't work via HDMi-DVI it was a last-chance saloon type effort to try it that way. But the colours and resolution were so poor that it was difficult to read any text, either near the screen or from far away.

I wonder if the programmers for 4.4 have put in any code for AV output? Possibly, but it would be a bit like fitting the wheels from a Trabant onto a Ferrari F40. Sure, it would go and maybe could even be driven for a few metres but anything more would be impossible.

I've got my known-to-be-working 4.4 install hooked up to my TV right now via the composite AV port, but am only getting some occasional single white random horizontal flickering lines on the screen, nothing at all resembling a picture.

I've tried booting via HDMI-HDMI, then swapping the cables over, then booting with both cables in and then taking the HDMI out, then booting with only the AV connected. But in that last case, if I then plug in the HDMI, I do get a picture on my monitor (doesn't matter if I plug or unplug the AV). So it seems as if autodetect for the AV video port has not been coded or enabled (or more likely, there are no AV drivers at all).



Extra question; does anyone have the occasional 'black screen' issues as mentioned in following quote from the ReadMe, especially during boot? (And I don't mean the 'Sleep function' which is set for me to the maximum 30 mins - very annoying in 4.4 that you can't turn it off altogether as in previous Android versions.)

Screen may go black, you need to press the Power switch on the device to turn on the screen.


That advice has no effect on my system, so I am usually forced to press the Reset switch.

roses2at replied at 2014-10-1 06:11
roses2at said:

What you've read is (with respect) not much use to me, as I've also read that partic ...

I had similar issue, and after trying 3 different hdmi/dvi monitors I dug out a 7" hdmi lcd touch screen

http://www.ebay.com/itm/7-AT070T ... hash=item2ecfe3e7dd

and was able after holding the power button IN for a few minutes/seconds until I heard the Android audio startup sound . I was able to even setup the bpi wifi adapter and go online, but at next boot when I tried a regular 17" hdmi/dvi screen it wouldn't bring up video although I did hear audio startup sound

I believe this lcd is egalax? derivative. I bought this for my raspberry pi but could not get touch to work. on bpi calibration still was needed to be done/reconfig because my movement in either axis was reversed.

You have to log in before you can reply Login | Sign Up

Points Rules