Bananian

bananian-1409 not boot at all

31 9663
neoe  
I tried it on several SD cards, but not boot, no light flashing, no hdmi output.

PS,
I feel so lucky that I selected Raspbian image as my first time os, and it is the only one works fine up to now.
Are you using the "DC-in" port for power supply?

neoe  
I tried both of 2 micro-usb ports on board, no lucky.

roshin  
Try to install 14.08 and update to 14.09. That worked for me.

tkaiser  
Reply 4# roshin

Try to install 14.08 and update to 14.09. That worked for me


There exists absolutely no reason for this. 14.09 works flawlessly unless something went wrong while downloading or writing to the SD card.

The Bananian developers provide image checksums ( https://www.bananian.org/download ) for a specific reason: To check whether the downloaded ZIP is intact (use the appropriate tool shasum on Linux or OS X and on Windows eg. Hash It. If the checksum matches then overwrite the whole SD card with it. And if the card isn't damaged and the board powered approriate (power-in not OTG) then it will boot into Bananian.

roshin  
I can confirm that I have had an intact image and that I used the right port for the power supply. I have the black banana pi case, which marks the ports clearly. For the images, I did check integrity and I even downloaded the images several times.

The assumption that no reason exists, is valid if (1) the update after 14.08 is 100% exactly the same as 14.09 image, and (2) the hardware is exactly the same. About (1), I don't have all the knowledge about the exact differences between the images, but I assume update from older version and boot directly from new image is not exactly the same, since in my case i couldn't run directly the new image, but succeeded after an update.
About (2), even if the banana pi is similar for everyone, there are still a few variables like power supply and the SD card used.

I found that  the power supply I initially used seemed to be weak and unstable. I suspect (I didn't test this) that the power supply I used, is good enough to boot 14.08 image, but not good enough to boot 14.09 image. The power supply I used was "rated" 2.1A, but I don't believe this.

(extra info: when i tried to boot 14.09, my router leased like 20 different ip's in like 10 minutes to my banana pi with which was shown with a weird device name)

tl;dr
If bananian is not booting, try old version (14.08) and check if the power supply really is strong and stable enough and check if the usb cable is fine.

tkaiser  
Reply 6# roshin

Maybe you're right that upgrading via bananian-update is somewhat different. This might be the case when U-Boot and the fex files wouldn't be exchanged when upgrading. Maybe Nico can comment on that...

BTW: the LeMaker guys changed power relevant stuff (voltages, USB OTG) in their 'official' fex file a few weeks ago:

https://github.com/linux-sunxi/s ... fe08d0e043ae8b187f5

I had the Bananian running for one day. Then I got strange output on HDMI and no reaction anymore. After power down/up only the red LED is on. I flashed the SD Card again and tried different power supplys. No result. On power only the red LED is on - no other LED. I have returned the board to seller for exchange.

Interesting...
U-boot is the only component not beeing updated by bananian-update. So this might cause the problem. I will take a further look at the differences betweeen 14.08 and 14.09 u-boot.

angeloD  
Edited by angeloD at Sat Nov 1, 2014 15:50

I confirm what roshin said.

Could not boot from 14.09, the banana went off after few seconds, dead.
I downloaded 14.08 and it booted with no problems.

Now comes the fun....I upgraded to 14.09 and now it does not boot again

You have to log in before you can reply Login | Sign Up

Points Rules