Lubuntu

1080p how?

6 5094
ipb  
I only managed to get 720p (default).
  1. root@lemaker:/home/bananapi# cat /sys/class/graphics/fb0/modes
  2. D:720x576p-50
  3. D:1920x1080i-50
  4. D:1280x720p-50
  5. D:720x480p-59
  6. S:1280x960p-60
  7. V:1024x768p-60
  8. V:800x600p-60
  9. V:640x480p-60
  10. D:1920x1080i-60
  11. D:1280x720p-60
Copy the Code
when I put one of those 1920 lines in /etc/rc.local it does not show X at all (X crashes)
  1. !/bin/sh -e
  2. #
  3. # rc.local
  4. #
  5. # This script is executed at the end of each multiuser runlevel.
  6. # Make sure that the script will "exit 0" on success or any other
  7. # value on error.
  8. #
  9. # In order to enable or disable this script just change the execution
  10. # bits.
  11. #
  12. # By default this script does nothing.

  13. echo D:1920x1080i-50 > /sys/class/graphics/fb0/mode
  14. exit 0
Copy the Code
ipb  
editing the uEnv file worked.

mount /dev/mmcblk0p1 /mnt
vi /mnt/uEnv.txt
and changed:
bootargs=console=ttyS0,115200 console=tty0 disp.screen0_output_mode=EDID:1280x720p60 hdmi.audio=EDID:0 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
to:
bootargs=console=ttyS0,115200 console=tty0 disp.screen0_output_mode=1920x1080p60 hdmi.audio=EDID:0 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait

Montala  
... so the only line which has effectively been changed is the middle one of the three?

ipb  
Yes. removed EDID and changed resolution.

Didn't change the settings in the first post though, there still there but does not seem to do anything.

Montala  
Thanks for your reply.

I am hoping to get mine set up tomorrow, so will see how it goes... fingers crossed!

tomafi  
If you still have issues with this, make sure you're using correct HDMI (1.4) cable.

I've spent soooo much time trying to get 1080p60 working and in the end I found out I was using bad cable.

See http://forum.lemaker.org/4852-1- ... n_1280x720p_50.html

PiTom  
In uEnv.txt, screen resoltuion, if you remove the "EDIT:" string from the setting,
you will disable the "probing for resolution"-from the PI to the Terminal.

Without the EDIT:  your PI will use "these" settings as "working set" and your terminal should "shine".

Works on HDMI to DVI cables as well.

You have to log in before you can reply Login | Sign Up

Points Rules