Android 4.2 For BananaPi------SD Card Setup

111 172784
dlanor  
Reply  dlanor

As I stated in the other thread, check this tool:  
It's free for personnal usage,  ...
ChrisP Posted at 2014-9-27 15:36


Thanks ChrisP, I've downloaded the tool and will install and test it shortly.

Funny thing! One of my other favorite tools is the "Paragon Partition Manager, Free Edition", also able to do some Ext4 manipulation. (Though not able to understand the Android SD card layouts.)

Best regards: dlanor

dlanor  
@ChrisP:
Installing that tool was a lot more complicated than your short tip indicated, so I'm describing it in some detail for others who may need it.

At first I found it impossible to install the version of extfs on the page you linked to, since it doesn't contain any registration link, nor is there any way to receive any serial number through the browsable parts of the paragon site (I did register as a customer first, but whenever I go to a download page, I'm automatically logged out again, so it's impossible to download anything there while logged in.) After a while I gave up on doing it this way, and instead searched for an older version of the software elsewhere on the net. That version did have a registration link inside the installer (above the registration fields), which allowed me to go to a non-browsable part of the paragon site (impossible to find from their home page or the new download page) and there get product key and serial number mailed to me, just like you said.

I then used that info to register and install the old version, and then again to update it to the current version (using the new installer).

The new version without any registration link is 2.353
The old version I found with registration link is 2.198

Others who need it can google for "Paragon_ExtFS_for_Windows_2.198.exe"

Best regards: dlanor

dlanor  
Post Last Edited by dlanor at 2014-9-30 08:19

Post Last Edited by dlanor at 2014-9-30 07:44

Here's a followup on my test of Paragon's extfs utility:

It does recognize one extfs partition on our Android cards, containing what should be part of the root partition (various folders with system apps etc). But it is only part of the root system, and is only half a GB in size, and there are 8 different partitions recognized only as "Unrecognized file system", as well as two incorrectly identified partitions. One of the latter is stated as FAT-16 and the other as FAT-32. But that is wrong! That last one is also mounted for access by Windows, but any attempt to access it through Windows Explorer will cause a freeze, possible to terminate only by forcibly terminating the Windows Explorer task through the task manager.

In short: Since only one of many partitions is correctly recognized, we can only do limited manipulations of the contents of that partition, and all partition size changes are impossible to do safely. (We must assume that even space between partitions may be used, as normal partitioning rules don't apply.)


Edit:
The above results were for an SD card which I later realized was for Android 4.4, and little used. I then repeated similar tests for my most used card with Android 4.2, which gave very different results. It had 4 partitions that were recognized as extfs, plus the usual group of unrecognizable blocks. But of the supposed extfs partitions only a few worked normally, including one of 1GB which I think matches our "0.98 GB internal flash space". But attempting to access some of the other extfs partitions caused a hard system crash (blue error screen) and reboot, so this kind of investigation is a risky business. Others doing this should make sure to have a fresh backup to revive the card from (like I did), as it is likely to be corrupted by system crash during access.

Best regards: dlanor

ChrisP  
Hi,

Apprently they changed something on their web site, I had a lot of effort to find back the page to ask for a serial for personnal usage: http://www.paragon-software.com/registration/extfs-windows.html

Regarding the number of partition recognized, it really depends of the images. On the 4.4 Beta 1, I can mount 3 partitions. On the image provided by mattrix, I can mount 4 partitions (in addition to the FAT32 one), but two partitions are not usefull, I think the half Gb is root as you said, and the 1 Gb is system.

I have another SD card where I do some test, and as you, I can only mount the half Gb partition. That's weird, I wonder if it's related to the disk geometry emulated by the sd card (number of cylinders ...).

dlanor  
Actually I was able to mount the 1 GB partition in one test, but that was the test whose final result was a system crash (when I attempted to open another partition). The fact that many blocks are shown with unidentified file systems indicates that the partition table is not reliable at all for access from Windows, probably not even for those filesystems which are properly identified. Some of what Windows sees as partition content links may in fact be unrelated data, specific to this weird Android-specific partition structure.

This need not hold us back from experimenting, but we must be prepared for all kinds of odd failures after modifications, and we'll need to be meticulous about backing up every step of progress before proceeding. Such backup is very time-consuming for large cards, so it may be a good idea to experiment with smaller cards to minimize backup time loss.

I'm not sure what the smallest allowed size is, but I think 4 GB should work.
(Though I'd never choose less than 16GB for non-experimental use.)

Best regards: dlanor

i got stuck on a screen that said 'android' with a green background

amalhasabear replied at Wed Nov 19, 2014 15:46
i got stuck on a screen that said 'android' with a green background

I get this same thing, it looks like it's only writing the bootloader and nothing else to the SD card, using an 8gb class 10 card.

Running windows 8.1, tried compatibility mode and with and without admin rights.

I also have no text in any of the buttons for the English version, is there a fixed version of Phoenix card?

dlanor  
Lots of people have reported problems when using Windows 8 or 8.1, but some of them solved it by installing and using a virtual machine with an older OS, such as Windows 7.

Best regards: dlanor

Image works great for me, though I have 2 questions

1. is there any way to edit script.bin or uEnv? I can't find it by mounting the SD card to my linux laptop (even though I can see the /system files in a partition). I need this in order to disable the blue LED for ethernet traffic. it's really bright and it's annoying during the night

2. I wrote the image to a 16GB card, and the partition structure is a bit weird. For example, if I try to download anything using any browser it says "no SD card". I tried unmounting and mounting but still the same. Also, in Settings -> Storage it says 1GB free space (for apps).. but I want to resize the entire free space left on the SD card for apps.

In conclusion, the questions are:
- can I disable the blue LED? I can tinker around if you give me some info
- can I resize the apps partition to fill the rest of the SD card? (~14gb)

Thanks!

ChrisP  
OverDark replied at Sun Nov 30, 2014 22:45
Image works great for me, though I have 2 questions

1. is there any way to edit script.bin or uE ...

Hi, regarding your first question I have no idea, but think you should go down to the sources and rebuilt from scratch.

Check this walkthrough for building instructions: http://forum.lemaker.org/thread- ... _2_build_guide.html
Just a litlle trick: apparently there is an issue with my last 3 commit (It was perfectly fine until I decided to rebuild a dev machine from scratch). So for now do a git reset hard to the last commit before my Mali 5 drivers.

Regarding your 2d question, follow this thread: http://forum.lemaker.org/thread- ... stem_partition.html
Actually the partition part is a bit tricky. Once you burn the sdcard you will see only one partition with 1 GB. But once the sdcard is booted on the bananaPi, the partition sizing will be based on the file sysconfig.lhs.
You have additionnal information

You have to log in before you can reply Login | Sign Up

Points Rules