Discussion

USB OTG script.bin

9 3178
Hi Everyone

I don't know how many are using the USB OTG port but I found it really good on android. Would be ace if the configuration kernal uImage and script.bin files were provided to enable this in the download area.

Anyone else think this is a good idea, because if your on windows and your BIN2FEX doesnt work.. your kinda in a bit of a misery
Post Last Edited by roses2at at 2014-10-5 07:36

Reply 1# orcaorcadia


   

Just in case you missed my reply in the other thread......


As I'm not a moderator, I don't have access to the Downloads area to upload files to.


The file you need is already in the forum, hidden deep in one of the threads, if you had tried to search.


But to make it easier 4 U, I am attaching it to this post.


Needs to be unzipped, and the script.bin file must be copied to the root partition (overwrite the old version, back it up first by renaming to script_old.bin first if you like) after burning your image and while the SD card is still attached to the reader. In Linux, this is straightforward to do. In Windows, you need a free program (Email registration needed) called Paragon ExtFS to be able to read the ext4 formatted disk.




It should work on all the Linux distros that LeMaker offer, but don't quote me on that or shoot me down in flames if it doesn't.



script for otg activation.rar (7.43 KB, Downloads: 146)

thanks man

You're welcome!

Did it work? Which distro are you using?

Would you like to test this file with some other distros and let us know in this thread if it works on those as well? That would be real nice of you..........

raspbian worked fine with it. but like you said it will work on all linux distros.

That's only what I've read - didn't actually try it for myself.

So please - if you can and if you want to - spend an hour or two doing some tests on the other OSs and let us know your results.

well it does work, am not sure if my pi has had a bit of damage lately but he seems to freeze alot, with or without the script enabled. especially if he is just doing general things like an apt-get. I'm fairly concerned. Its like he overheats or something and freezes.

Post Last Edited by roses2at at 2014-10-5 18:39

Post your complete message with as much other relevant information as possible (eg what type of power supply you are using (how many amps), if you have any USB devices plugged in and what they are, if you have a passive or powered USB hub, if you are overclocking, etc) in the Troubleshooting section of this Forum:

http://forum.lemaker.org/forum-9-1-troubleshooting.html

im using a usb keyboard and mouse with the otg disabled at the moment and a 5v 1amp power supply that a htc charger would use.

I am going to buy a new charger and see if the official raspberry one is what i actually need. I know 2A is the standard level of power it should need and have, but my last charger died so i have no choice but to use the 1amp charger. I think its cutting out as the processor does more work, warms up, and subsequently needs more current than my supply can deliver. would this be a good analysis of whats going on?

Into the Troubleshooting forum please - it is now a bit too much off-topic for here. Thx.

You have to log in before you can reply Login | Sign Up

Points Rules