Lubuntu

lirc irrecord, new remote how?

6 10766
ipb  
based on http://linux-sunxi.org/LIRC I installed lirc.
  1. sudo apt-get install lirc
  2. dmesg |grep sunxi-ir
  3. [    2.390612] input: sunxi-ir as /devices/virtual/input/input0
Copy the Code
Editted /etc/lirc/hardware.conf to fit the input number above:
  1. REMOTE_DRIVER="devinput"
  2. REMOTE_DEVICE="/dev/input/event0"
  3. START_LIRCD="true"

  4. /etc/init.d/lirc restart
Copy the Code
with irc and a temporary config I was able to see keypresses. Then I wanted to have a valid configuration for my device:
  1. /etc/init.d/lirc stop
Copy the Code
create a new remote configuration:
  1. irrecord --driver=devinput --device=/dev/input/event0 ~/lircd.conf
Copy the Code
The program tells me to hold down a button. Holding it down for a long time but no dots appear. Only when releasing the button I get one dot (tried multiple remotes):

  1. Press RETURN to continue.


  2. Hold down an arbitrary button.
  3. .irrecord: gap not found, can't continue
  4. irrecord: closing '/dev/input/event0'
  5. root@lemaker:~#
Copy the Code
any suggestions?
Hi ,  i have ever met some similar problems as you .  I pressed the key ,but appear nothing , and got a timeout warning . Then ,i got another ir remote to try again , it works !!! Maybe the irrecord program doesn't support every remote well. So ,try another may help.

axelf  
Hi, same problem here. Tried several remotes and none worked. Is there any solution yet for this issue?
Thanks!

boy011  
axelf replied at Mon Jan 5, 2015 08:03
Hi, same problem here. Tried several remotes and none worked. Is there any solution yet for this iss ...

If you can find it ,maybe you can try these kings of remotes:
1420683656938.jpg

schasch  
did anyone solve the problem?

irrecord --driver=devinput --device=/dev/input/event0 /my-lircd.conf

Press RETURN to continue.
Hold down an arbitrary button.
..
irrecord: gap not found, can't continue
irrecord: closing '/dev/input/event0'
...
..
.

seems the ir-driver supports only NEC protocol.

so,just to be sure,try with a remote using NEC

schasch  
thanks sashijoseph,
(I am surprised to get an answer in this 'official bananian-'forum !)

I tested several remotes. 1 is recognized by the bpi-r1. I wrote an own c-prog wich reads from input.
That way I can switch green LED on or off by reading the inputdata.
But irrecord does not work with the remote.
I do not know if the remote supports NEC or not. (its the default remote from my coolstream NEO (with neutrino-linux).

On this site:
http://www.vdr-portal.de/board16 ... ana-pi/#post1223318
...they write that it is a driver problem with "sunxi_ir" and they work with "sunxi_lirc" -driver...
But on bananian I can't find a way to load those modules or unload the modules on Bananian-1508.
Compiling my own kernel on Bananian-1508 does not work too on my R1 (see my question in an other thread)
regards

You have to log in before you can reply Login | Sign Up

Points Rules