Bananian

tvheadend on Bananian

30 12269
Ra:)  
I'm using BPI with tvheadend for some time... But, phildapunk, what for do you want to use transcoding capability? In my case (with earlier versions of TVH) even on SD streams i got 100% CPU load (at 1200 MHz) and it is still not enough...

maxwell  
Hello,
I could think of the need to just transcode audio for example, not the video. BPi may be capable of that on the fly. I could use that for my Chromecast, as it cannot handle many audio formats. Flipping through the TVH client on my android phone and casting it to my TV. Just a thought...

Ra Is that a CPU value while transcoding? I am confused here.

Ra:)  
Yes. My BPi slightly overclocked - not really big difference with stock clocks. For audio only - no problems at all...

Ra replied at 2014-10-20 03:22
I'm using BPI with tvheadend for some time... But, phildapunk, what for do you want to use transcodi ...

Hi Ra

I'm trying to use tvheadend through a Plex Media server plugin, which will allow me to stream tvheadend content to any plex client.

I need the transcoding option to stream the content to my apple devices  , iphone, iPad.

Unfortunately without transcoding enabled the stream fails.  Works without a problem to VLC & Plex on my desktop machines.

I'm also running Tvheadend on the Banana Pi, but I'm seeing the infamous "continuitu counting error". It happens sporadically and as fas as I can tell it's not a performance issue: cpu load is minimal. I suspect it has something to do with the ethernet driver. I tried tuning the TCP stack and even assigning eth0 to its own cpu, but to no avail.

Anyone else ran into this?

Ra:)  
Anyone else ran into this? - no...

It seems in order to enable transcoding just newest libav is needed... But i can't get it to work properly...

I traced the problem to VLANs. When I disable VLANs the problem goes away. I suspect that there's something wrong with the network stack and that when VLANs are enabled packets get lost occasionally. Ho hum.

But maybe the problem is broader than just VLANs, because I've also seen tvheadend losing the connection entirely: "no transponder availiable for subscription". I've seen this error a couple of times, both with and without VLANs.

Now where to file a bug report?

Thanks, I've reported the issue there. But AFAIK the problem is with the sunxi gmac code. So a better place would be to report it there, but do they have a bug tracker?

You have to log in before you can reply Login | Sign Up

Points Rules