Bananian

Any hints about php 5.5 or 5.6?

6 4605
lezef  
Hi,

I've just installed Bananian on my latest Banana Pi and everything works just fine!
I did it because I want to upgrade my local web / NAS server.
The old one (Raspberry PI with a ligth Arch Linux distrib) have the latest PHP / MySQL (MariaDB) versions. Everything is working fine, too.
So, I'm asking if there's any hint about upgrading PHP to the last two earlier versions?
I tried to find anything on Google, but it seems impossible, as Wheezy is just running version 5.4 and no PPA for arm V7.

So if anyone has something about it, it would be nice.
lezef  
Finally,

I've found this : https://nicolas.steinmetz.fr/blog/post/PHP-5.5.17-(dotdeb)-pour-cubietruck-(armhf)
And, you know what? It works fine!
The only issue is that you have to wait for 1500 seconds to compile the entire PHP 5.5 DotDeb's repo...

I think this is solving that question.

lezef  
Few notes about this dotdeb repo:
  • There's no way to install xdebug
  • no php5-pear/pecl
  • no php5-imagick
  • no php5-geoip


Also:
apt-get install php5-{something} doesn't seem to work, too.

So be careful if you want a complete PHP 5.5 suite on your Banana Pi's server.

lezef  
Finally,

xDebug: problem solved!
You have to
  1. apt-get install php-pear
Copy the Code
(not php5-pear)
then
  1. pecl install xdebug
Copy the Code
And set xdebug.so into php.ini file (as the installer displays the exact link)

Smashing!

lezef  
Ok,
it seems that the previous link up there was wrong.
So: https://nicolas.steinmetz.fr/blog/post/PHP-5.5.17-%28dotdeb%29-pour-cubietruck-%28armhf%29

lezef  
Edited by lezef at Tue Nov 4, 2014 10:20

Works also with PHP 5.6.2! Even better, with xDebug and many more features!! Just change the deb with php56
But I have to say that it takes A VERY LONG TIME to compile and install. You must be patient around 7 hours straight...

lezef  

You have to log in before you can reply Login | Sign Up

Points Rules