Trouble

SATA trouble

32 22451
MrK1982  
Hi pieter,
actually I think its a driver or a powering problem. I tested multiple drives and two different sata cables . The same problem occurs on any of those configurations. There must be an internal problem related to the banana pi sata power or to the sata driver built into bananian. Next step (propably this evening) is testing the drives by powering them from an external 5V source. If this ends up in a functional system there has to be a problem related to the sata power connector. If the problem is still persistent then I dare to say there is a problem related to the used sata driver in bananian.

MrK1982  
By the way I suggest you disconnect your drive until this problem is solved. I use an old 40gb sata drive for further testing cause the high amount of load cycles couldn't be healthy for the drive.

pieter  
Dear Mrk,

Thank you,  The blue WD drive is not connected anymore since a couple of days.  Please keep us in the loop of your findings.

Kind regards, Pieter

You should try measuring the 5V at the SATA power connector or GPIO header, to make sure you are getting 5V

pieter  
Thank you, will measure the voltage.

pieter  
Dear,

The older power supply delivers 4.8V on the SATA drive connector (the white one) - although it is 2A, I replaced it by another one - from a apple IPAD2 - now it seems to be OK - although slow - until I rebooted.

Now it is again problematic:
ata1.00: failed command: READ FPDMA QUEUED
[  257.419039] ata1.00: cmd 60/00:88:e0:0b:25/01:00:01:00:00/40 tag 17 ncq 131072 in
[  257.419047]          res 41/40:00:e0:0b:25/00:00:01:00:00/40 Emask 0x409 (media error) <F>
[  257.422051] ata1.00: status: { DRDY ERR }
[  257.424515] ata1.00: error: { UNC }
[  257.429189] ata1.00: configured for UDMA/133
[  257.431422] ata1: EH complete

Note that I have on the GPIO an DS1820 and a led - I'll remove these to see it helps.

Kind regards, Pieter

Someone in another thread mentioned his hdd was working ok in Bananian but not with other distros.
Could you test with Bananian and see if it makes a difference,although I can't see how.

pieter  
to sashijoseph

Thank you, so I removed the gpio connector, and tried with another disk and with bananian. Could not mount the drive, seeing errors in dmesg.  now I have an external USB drive (external powered) - this works.  

connecting any 2.5 inch USB disk to the USB connector shuts down the BPI.  Next what I'll try will be a 2.5 blue WD disk to the SATA connector but disk will be externally powered.

Kind regards,
Pieter

yes...powering externally will put to rest doubts whether the sata interface/driver is at fault or the pi's power management.

Post Last Edited by mikronauts at 2014-8-28 21:09

Post Last Edited by mikronauts at 2014-8-28 16:09

I'll try to replicate the issue this weekend, I've been meaning to try an SSD on my Banana.

I'll report my findings.

(update: I have schematics now!)

You have to log in before you can reply Login | Sign Up

Points Rules