Bananian

Unable to connect to internet (WWW)

5 3226

Hi,

I use a Ralink RT5370 WiFi Dongle with my banana pi and I am unable to connect to Internet. I don't have any issues connecting it to my local LAN and I can easily ssh to it on my Lan to do basic operations. A strange thing I have observed is I am unable to use Samba services. I have set up a transmission+samba box and was wanting to run it without an Ethernet cable. Can someone please help me on this? Sorry for starting a new thread as I didn't find any thread with this problem

Thanks
Sry, people say that should work on Raspbian:
http://forum.lemaker.org/forum.p ... 77&fromuid=1602

gbi  

Hi,

Thanks for the replies.

I tried installing all the packages as told by you in your post
Configured my wpa_supplicant.conf with my ssid details
Configured my interfaces and linked the wpa_supplicant.conf

But still the issue is resolved. I can ssh into the bananapi with my wifi dongle but unable to establish a link to the internet.

gbi  
sansfaille replied at Thu Oct 23, 2014 19:11
Hi,

Thanks for the replies.

Hi,

maybe you have an issue with routing, or firewall rules. Maybe.

Show me the output of a 'netstat -rn' and look for the defaultgateway.

Do an 'ifconfig wlanx' (x whatever your WLAN adapter is).

Do a 'ping ip-of-wlanx' and look if you get replies.

Do a 'ping ip-of-defaultgateway' and look if you get replies.

Do you have firewall rules on the BaPi. Do an 'iptables -vL' to list them.

If your BaPi gets it's IP address and so on over DHCP, look for it's nameservers. Do a 'cat /etc/resolv.conf' and look for them.

If nothing of the above works, do a 'dmesg | grep -i wlan -A3 -B3' and post it.

cheers

@GBI

Hi sorry for the late replies as I had given up hopes that someone would help me.. Many thanks for your reply.
And I figured out what was wrong with your help. The default gateway was missing and I added it and now it works.. Thanks a lot for your help


For anyone who has the same problem please make sure that you add the default gateway of your router
ip route add default via 192.168.0.1
Note:192.168.0.1 is my default gateway, modify it according to your router settings

Thanks

You have to log in before you can reply Login | Sign Up

Points Rules