Rooting BananaPi

11 8540
Hi,As you know there is a SD Card bug in Android. I wanted to fix this bug, and I'm know how to do it.
I plugged my disc to usb, and I wanted to change /etc/fstab file to point my disc as /mnt/sdcard. But I don't have right to write this file. I tryed to root it by Framaroot  but it won't work. I tryed to extract img file and modify it, but I failed it ;-) How can I root my BananaPi?
Did you try the new root method for the S5? T
It's called towelroot worked on the S5 easy.
Supposed to work on all kind of devices.

Yeap ;-) towelroot helped! thank you! ;)

How does one install towelroot? If I try to download the apk using the browser it complains there is no sd card. Which is the reason I need towelroot ...

OK. I copied the apk to the FAT32 fs on the sdcard (using pc). Then I could install it using the file browser (SD card/C). However everytime I start the root process the banana pi hangs and I have to reset it.
But after that I could install supersu and RootChecker says  the device is rooted. Maybe it already was or TowelRoot really did work.
Unfortunately I still cannot edit the fstab fle since the filesystem is mounted readonly.

Found I had to 'mount -o remount,rw /system' to be able to save the modified fstab file. Unfortunately now it does not start anymore. The android animation starts but never ends. Tried it twice (put # before the mount command).

Reply 6# wdehoog

Our engineer is planning to solve this problem. I have a workaround, but not the right method to do so

I found that the Android image is already rooted.

Also, TowelRoot doesn't seem to work on the Android image (maybe because it's already rooted)

Like mattrix said, the Android image is already rooted, though some tools still need to be told to use root access since they have it disabled by default as a safety precaution. One of the best tools of this kind is "ES File Explorer" where you can simply change the parameter "Root Explorer" from its default "OFF" value to the "ON" value which enables read-write access to the root folders.

As for the issue with /sdcard mounting, I solved this problem for my own use earlier today, and have written a simple tutorial for others who may want to do it the same way. Doing so is extremely simple, as it only involves changing a single bit in a single file (changing a "2" character into "0"), for which you can use the "ES Note Editor" which is included with the "ES File Explorer".

The file affected by my change is "/etc/vold.fstab".

You can read all about it in the separate thread where I posted that tutorial.

Best regards: dlanor

Also consider using SuperSu which lets you give root access to certain apps when required. ... e.supersu&hl=en

You have to log in before you can reply Login | Sign Up

Points Rules