Other OS

kali image download

10 5611
cracker  
hi all
I just builded a kali image
download link ,download password:v129
____
  •     Based on Kali 1.0.9
  •     root password is toor
  •     /etc/apt/sources.list changed to a mirror in China, I'm chinese
  •     eth0 and wireless RT3070 worked well
  •     enjoy it  

Thanks for sharing!

dylan  
Edited by dylan at Mon Nov 10, 2014 07:49

Very Good! Could you share the method that you making the kali system ?
where can i download the file system for ARM architecture ?
Thanks!

cracker  
dylan replied at Mon Nov 10, 2014 07:40
Very Good! Could you share the method that you making the kali system ?
where can i download the fi ...

see here Setting up the Linux distribution root file system

dylan  
Thanks for your answer . . .

gbi  
Hi,

how stable/bugfree/.. is Kali running on the BaPi ?

Is it recompiled for the BaPi or is it based on the Raspi Kali ?

Thanks in advance.

cracker  
Edited by cracker at Tue Dec 9, 2014 20:47
gbi replied at Fri Dec 5, 2014 02:09
Hi,

how stable/bugfree/.. is Kali running on the BaPi ?


Recompiled kernel and u-boot completely
Root-fs copied from kali's repository

By the way,it has nothing to do with Raspi Kali

gbi  
Hi,

thanks a lot for clarification

gbi  
Edited by gbi at Mon Dec 15, 2014 09:33

Hi,

@Cracker:

I have given your image a try, but no real success so far

The LEDs are blinking (also the blue one), but I have problems wih HDMI. I only get some messages regarding EDID (sorry, dont have them noticed) but no prompt to login (neither textual nor X11). I have the sneaking suspicion that my LCD display and the BaPi are trying to negotiate a common graphicsmode, but do not find one. My display only has 1280x1024 as highest resolution.

In the moment I have also changed the bootargs line in /boot/uEnv.txt to disp.screen0_output_mode=EDID:1024x768p50, maybe that works, but I cannot test in the moment.


Also I'm not able to login via ssh. I can see that there is the usual /etc/init.d/ssh script and also /etc/ssh/sshd_config set to port 22 (so sshd at least seems to be installed, it's binary is also in place). But in /etc/rc[2345].d are only symlinks to K01ssh, so no wonder ssh doesn't get started. As runlevel 2 is the default runlevel of your image, maybe a "mv K01ssh S02ssh" in /etc/rc2.d helps a little bit regarding ssh

cheers

EDIT: only for the records

changing disp.screen0_output_mode to =EDID:1024x768p50 indeed helped to get the console up and running
Network and SSHD also works.

So far so good :-)

Edited by omgitsthomas at Sun Dec 28, 2014 23:52

That download page is very slow for me. Could you upload it to Mega by chance? Or some other mirror?

Thanks.

[Edit] Never mind, I downloaded it. Took a while :p I can upload it to a US mirror if anyone requests it.

You have to log in before you can reply Login | Sign Up

Points Rules